we don't need the libiptc library
[openwrt/svn-archive/archive.git] / package / iptables / Makefile
index 9d6d8f842395fa72111c03e1212197259df62449..cfce37769ceff86b17e5f8ce90e58b2abc93a160 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -13,14 +12,15 @@ PKG_NAME:=iptables
 
 ifeq ($(CONFIG_LINUX_2_4),y)
   PKG_VERSION:=1.3.8
-  PKG_RELEASE:=3
+  PKG_RELEASE:=4
   PKG_MD5SUM:=0a9209f928002e5eee9cdff8fef4d4b3
+  MAKE_TARGETS:=experimental install-experimental install-devel
 endif
 
 ifeq ($(CONFIG_LINUX_2_6),y)
-  PKG_VERSION:=1.4.0
+  PKG_VERSION:=1.4.3.2
   PKG_RELEASE:=1
-  PKG_MD5SUM:=90cfa8a554a29b0b859a625e701af2a7
+  PKG_MD5SUM:=545698693b636cfc844aafc6729fd48a
 endif
 
 PKG_VERSION?=<IPTABLES_VERSION>
@@ -55,20 +55,38 @@ define Package/iptables
 $(call Package/iptables/Default)
   TITLE:=IPv4 firewall administration tool
   MENU:=1
+  DEPENDS+= +kmod-ipt-core
 endef
 
-define Package/iptables/conffiles
-/etc/firewall.config
-/etc/firewall.user
+define Package/iptables/description
+ IPv4 firewall administration tool.
+ Includes support for:
+ - limit
+ - LOG
+ - mac
+ - multiport
+ - REJECT
+ - TCPMSS
 endef
 
 define Package/iptables-mod-conntrack
 $(call Package/iptables/Module, +kmod-ipt-conntrack)
-  TITLE:=connection tracking modules
+  TITLE:=Basic connection tracking extensions
 endef
 
 define Package/iptables-mod-conntrack/description
- iptables extensions for connection tracking.
+ Basic iptables extensions for connection tracking.
+ Includes:
+ - state
+endef
+
+define Package/iptables-mod-conntrack-extra
+$(call Package/iptables/Module, +kmod-ipt-conntrack-extra)
+  TITLE:=Extra connection tracking extensions
+endef
+
+define Package/iptables-mod-conntrack-extra/description
+ Extra iptables extensions for connection tracking.
  Includes:
  - libipt_conntrack
  - libipt_helper
@@ -77,18 +95,18 @@ endef
 
 define Package/iptables-mod-filter
 $(call Package/iptables/Module, +kmod-ipt-filter)
-  TITLE:=filter modules
+  TITLE:=Content inspection extensions
 endef
 
 define Package/iptables-mod-filter/description
  iptables extensions for packet content inspection.
  Includes:
- - libipt_ipp2p
+ - libipt_string
  - libipt_layer7
 endef
 
 define Package/iptables-mod-imq
-$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_25)
+$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_27)
   TITLE:=IMQ support
 endef
 
@@ -100,11 +118,11 @@ endef
 
 define Package/iptables-mod-ipopt
 $(call Package/iptables/Module, +kmod-ipt-ipopt)
-  TITLE:=IP/Packet option modules
+  TITLE:=IP/Packet option extensions
 endef
 
 define Package/iptables-mod-ipopt/description
- iptables extensions for matching/changing IP packet options.\\\
+ iptables extensions for matching/changing IP packet options.
  Includes:
  - libipt_CLASSIFY
  - libipt_dscp/DSCP
@@ -121,7 +139,7 @@ endef
 
 define Package/iptables-mod-ipsec
 $(call Package/iptables/Module, +kmod-ipt-ipsec)
-  TITLE:=IPSec extensions
+  TITLE:=IPsec extensions
 endef
 
 define Package/iptables-mod-ipsec/description
@@ -134,13 +152,26 @@ endef
 
 define Package/iptables-mod-nat
 $(call Package/iptables/Module, +kmod-ipt-nat)
-  TITLE:=extra NAT targets
+  TITLE:=Basic NAT extensions
 endef
 
 define Package/iptables-mod-nat/description
- iptables extensions for different NAT targets.
+ iptables extensions for basic NAT targets.
  Includes:
- - libipt_REDIRECT
+ - MASQUERADE
+ - SNAT
+ - DNAT
+endef
+
+define Package/iptables-mod-nat-extra
+$(call Package/iptables/Module, +kmod-ipt-nat-extra)
+  TITLE:=Extra NAT extensions
+endef
+
+define Package/iptables-mod-nat-extra/description
+ iptables extensions for extra NAT targets.
+ Includes:
+ - REDIRECT
 endef
 
 define Package/iptables-mod-ulog
@@ -156,7 +187,7 @@ endef
 
 define Package/iptables-mod-iprange
 $(call Package/iptables/Module, +kmod-ipt-iprange)
-  TITLE:=ip range module
+  TITLE:=IP range extension
 endef
 
 define Package/iptables-mod-iprange/description
@@ -167,27 +198,23 @@ endef
 
 define Package/iptables-mod-extra
 $(call Package/iptables/Module, +kmod-ipt-extra)
-  TITLE:=other extra iptables extensions
+  TITLE:=Other extra iptables extensions
 endef
 
 define Package/iptables-mod-extra/description
  other extra iptables extensions.
  Includes:
- - libipt_limit
  - libipt_owner
  - libipt_physdev
  - libipt_pkttype
  - libipt_recent
  - iptable_raw
  - libipt_NOTRACK
- - libipt_TARPIT
- - libipt_DELUDE
- - libipt_CHAOS
 endef
 
 define Package/iptables-mod-ipset
 $(call Package/iptables/Module, +kmod-ipt-ipset)
-  TITLE:=ipset iptables extension
+  TITLE:=IPset extension
 endef
 
 define Package/iptables-utils
@@ -214,12 +241,21 @@ define Build/Prepare
        $(call Build/Prepare/Default)
 endef
 
-define Build/Configure
+ifeq ($(KERNEL),2.4)
+  define Build/Configure
        chmod a+x $(PKG_BUILD_DIR)/extensions/.*-test*
        rm -f $(PKG_BUILD_DIR)/.configured*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                clean
-endef
+  endef
+endif
+
+TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+       --enable-devel \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-xtlibdir=/usr/lib/iptables
 
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
@@ -230,29 +266,15 @@ define Build/Compile
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                KBUILD_OUTPUT="$(LINUX_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all experimental install install-experimental
+               all install $(MAKE_TARGETS)
 endef
 
 define Build/InstallDev
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPT_FLAGS="$(TARGET_CFLAGS)" \
-               KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
-               KBUILD_OUTPUT="$(LINUX_DIR)" \
-               DESTDIR="$(1)" \
-               install-devel
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/include $(1)/usr
-       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(1)/usr/lib
 endef
 
 define Package/iptables/install
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/firewall.config $(1)/etc/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
-       $(INSTALL_BIN) ./files/firewall.user $(1)/etc/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) ./files/firewall.awk $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/iptables
@@ -305,6 +327,7 @@ L7_INSTALL:=\
 $(eval $(call BuildPackage,iptables))
 $(eval $(call BuildPackage,iptables-utils))
 $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
+$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipset,$(IPT_IPSET-m)))
 $(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
@@ -312,6 +335,7 @@ $(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
 $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
+$(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
 $(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
 $(eval $(call BuildPackage,ip6tables))