we don't need the libiptc library
[openwrt/svn-archive/archive.git] / package / iptables / Makefile
index dfe7cac240196312b3d689c98d2c4cf831c11e07..cfce37769ceff86b17e5f8ce90e58b2abc93a160 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -19,9 +18,9 @@ ifeq ($(CONFIG_LINUX_2_4),y)
 endif
 
 ifeq ($(CONFIG_LINUX_2_6),y)
-  PKG_VERSION:=1.4.1.1
+  PKG_VERSION:=1.4.3.2
   PKG_RELEASE:=1
-  PKG_MD5SUM:=723fa88d8a0915e184f99e03e9bf06cb
+  PKG_MD5SUM:=545698693b636cfc844aafc6729fd48a
 endif
 
 PKG_VERSION?=<IPTABLES_VERSION>
@@ -102,7 +101,7 @@ endef
 define Package/iptables-mod-filter/description
  iptables extensions for packet content inspection.
  Includes:
- - libipt_ipp2p
+ - libipt_string
  - libipt_layer7
 endef
 
@@ -211,9 +210,6 @@ define Package/iptables-mod-extra/description
  - libipt_recent
  - iptable_raw
  - libipt_NOTRACK
- - libipt_TARPIT
- - libipt_DELUDE
- - libipt_CHAOS
 endef
 
 define Package/iptables-mod-ipset
@@ -254,8 +250,12 @@ ifeq ($(KERNEL),2.4)
   endef
 endif
 
+TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
 TARGET_CFLAGS += $(FPIC)
-CONFIGURE_ARGS += --enable-devel --with-xtlibdir=/usr/lib/iptables 
+CONFIGURE_ARGS += \
+       --enable-devel \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-xtlibdir=/usr/lib/iptables
 
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
@@ -272,7 +272,6 @@ endef
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/include $(1)/usr
-       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(1)/usr/lib
 endef
 
 define Package/iptables/install