revert [8415], seems to be causing problems for the kernel build
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index e58b310259cbc8daf1f41a9ee27086ce4a232745..3ec07d43ac5deef00630a84d5354870bb15c3e56 100644 (file)
@@ -14,9 +14,7 @@ PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
 PKG_RELEASE:=$(LINUX_RELEASE)
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-
-# build all in-tree kmod-* packages by default
-KMOD_DEFAULT:=m
+SCAN_DEPS=modules/*.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
@@ -49,13 +47,7 @@ define Package/kernel/install
   # nothing to do
 endef
 
-# this is more robust than ifdef around eval/call
-ifneq ($(DUMP),1)
-  define BuildKernel
-    $(call BuildPackage,kernel)
-  endef
-endif
-$(eval $(call BuildKernel))
+$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
 include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk