tools: add b43-tools
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index a030ad7236d13d2365f2e84714655d13e1d39d05..8050817392b271f405de8410d6fac33fd491ef6c 100644 (file)
@@ -1,25 +1,22 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
-PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
-PKG_RELEASE:=$(LINUX_RELEASE)
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
-  NF_KMOD:=1
-  include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Build/Prepare
@@ -38,21 +35,15 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  DESCRIPTION:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
+  URL:=http://www.kernel.org/
 endef
 
 define Package/kernel/install
   # nothing to do
 endef
 
-# this is more robust than ifdef around eval/call
-ifneq ($(DUMP),1)
-  define BuildKernel
-    $(call BuildPackage,kernel)
-  endef
-endif
-$(eval $(call BuildKernel))
+$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
+-include $(TOPDIR)/target/linux/*/modules.mk