[package] kernel/modules: Add zlib package
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index 0bc7c0ac5b0486c9d1014dcb890b13c0c51471df..d3823547aa3acac5eefd9b43641b047ca1d9cd77 100644 (file)
@@ -1,15 +1,15 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
 SCAN_DEPS=modules/*.mk
@@ -17,8 +17,6 @@ SCAN_DEPS=modules/*.mk
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
-  NF_KMOD:=1
-  include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Build/Prepare
@@ -37,8 +35,8 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  DESCRIPTION:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+  URL:=http://www.kernel.org/
 endef
 
 define Package/kernel/install
@@ -47,5 +45,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk
+-include $(TOPDIR)/target/linux/*/modules.mk