[package] kernel/modules: Add zlib package
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index 8f98be384cfbd1bd6f1ab62be55ed88a7e2f4075..d3823547aa3acac5eefd9b43641b047ca1d9cd77 100644 (file)
@@ -1,28 +1,22 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
-PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
-PKG_RELEASE:=$(LINUX_RELEASE)
+PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-
-# build all in-tree kmod-* packages by default
-KMOD_DEFAULT:=m
+SCAN_DEPS=modules/*.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
-  NF_KMOD:=1
-  include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Build/Prepare
@@ -41,8 +35,8 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  DESCRIPTION:=Virtual kernel package
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+  VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+  URL:=http://www.kernel.org/
 endef
 
 define Package/kernel/install
@@ -51,5 +45,5 @@ endef
 
 $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk
+-include $(TOPDIR)/target/linux/*/modules.mk