add phidget kernel module from #4116
[openwrt/svn-archive/archive.git] / package / kernel / Makefile
index bc0b88ba2f754c384d129ba1b0e0afc5f6033d80..da96f43a7b414b14450614c0ffe38a58b3a40b3a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,20 +10,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
-PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
-PKG_RELEASE:=$(LINUX_RELEASE)
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-PKG_FILE_DEPEND:=$(MODULES_DIR)
-
-# build all in-tree kmod-* packages by default
-KMOD_DEFAULT:=m
+SCAN_DEPS=modules/*.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
-  NF_KMOD:=1
-  include $(INCLUDE_DIR)/netfilter.mk
 endif
 
 define Build/Prepare
@@ -42,7 +35,6 @@ define Package/kernel
   CATEGORY:=Kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
-  DESCRIPTION:=Virtual kernel package
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
 endef
 
@@ -50,13 +42,7 @@ define Package/kernel/install
   # nothing to do
 endef
 
-# this is more robust than ifdef around eval/call
-ifneq ($(DUMP),1)
-  define BuildKernel
-    $(call BuildPackage,kernel)
-  endef
-endif
-$(eval $(call BuildKernel))
+$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
-include $(TOPDIR)/target/linux/*/modules.mk
+-include $(TOPDIR)/target/linux/*/modules.mk
 include ./modules/*.mk