kernel: kmod-scsi-core: fix load on install
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / block.mk
index afa0cd3349ecb73ca5630d8d7acc2bb9786fd94e..ccbb0805c8b44006da4d34c55a9a31087b07e2e6 100644 (file)
@@ -616,9 +616,9 @@ define KernelPackage/scsi-core
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
   FILES:= \
-       $(if $(findstring y,$(CONFIG_SCSI)),,$(LINUX_DIR)/drivers/scsi/scsi_mod.ko) \
+       $(LINUX_DIR)/drivers/scsi/scsi_mod.ko \
        $(LINUX_DIR)/drivers/scsi/sd_mod.ko
-  AUTOLOAD:=$(call AutoLoad,40,sd_mod,1)
+  AUTOLOAD:=$(call AutoLoad,40,scsi_mod sd_mod,1)
 endef
 
 $(eval $(call KernelPackage,scsi-core))