build: remove obsolete references to cris and avr32
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / fs.mk
index 70387fd99d197573cd95d93e601cccc74dd61ca0..64182e680d46c6fa813205d80e59d6a6faff3c5a 100644 (file)
@@ -7,6 +7,43 @@
 
 FS_MENU:=Filesystems
 
+define KernelPackage/fs-fscache
+  SUBMENU:=$(FS_MENU)
+  TITLE:=General filesystem local cache manager
+  DEPENDS:=
+  KCONFIG:=\
+       CONFIG_FSCACHE=m \
+       CONFIG_FSCACHE_STATS=y \
+       CONFIG_FSCACHE_HISTOGRAM=n \
+       CONFIG_FSCACHE_DEBUG=n \
+       CONFIG_FSCACHE_OBJECT_LIST=n \
+       CONFIG_CACHEFILES=y \
+       CONFIG_CACHEFILES_DEBUG=n \
+       CONFIG_CACHEFILES_HISTOGRAM=n
+  FILES:=$(LINUX_DIR)/fs/fscache/fscache.ko
+  AUTOLOAD:=$(call AutoLoad,29,fscache)
+endef
+
+$(eval $(call KernelPackage,fs-fscache))
+
+define KernelPackage/fs-afs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Andrew FileSystem client
+  DEPENDS:=+kmod-rxrpc +kmod-dnsresolver +kmod-fs-fscache
+  KCONFIG:=\
+       CONFIG_AFS_FS=m \
+       CONFIG_AFS_DEBUG=n \
+       CONFIG_AFS_FSCACHE=y
+  FILES:=$(LINUX_DIR)/fs/afs/kafs.ko
+  AUTOLOAD:=$(call AutoLoad,30,kafs)
+endef
+
+define KernelPackage/fs-afs/description
+  Kernel module for Andrew FileSystem client support
+endef
+
+$(eval $(call KernelPackage,fs-afs))
+
 define KernelPackage/fs-autofs4
   SUBMENU:=$(FS_MENU)
   TITLE:=AUTOFS4 filesystem support
@@ -16,7 +53,7 @@ define KernelPackage/fs-autofs4
 endef
 
 define KernelPackage/fs-autofs4/description
 Kernel module for AutoFS4 support
+ Kernel module for AutoFS4 support
 endef
 
 $(eval $(call KernelPackage,fs-autofs4))
@@ -25,7 +62,7 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +LINUX_3_10:kmod-lib-raid6 +LINUX_3_10:kmod-lib-xor
+  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib +kmod-lib-raid6 +kmod-lib-xor
   KCONFIG:=\
        CONFIG_BTRFS_FS \
        CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -36,7 +73,7 @@ define KernelPackage/fs-btrfs
 endef
 
 define KernelPackage/fs-btrfs/description
 Kernel module for BTRFS support
+ Kernel module for BTRFS support
 endef
 
 $(eval $(call KernelPackage,fs-btrfs))
@@ -59,7 +96,7 @@ define KernelPackage/fs-cifs
     +kmod-crypto-md4 \
     +kmod-crypto-des \
     +kmod-crypto-ecb \
-    +!LINUX_3_3&&!LINUX_3_6:kmod-crypto-sha256
+    +kmod-crypto-sha256
 endef
 
 define KernelPackage/fs-cifs/description
@@ -84,13 +121,28 @@ endef
 
 $(eval $(call KernelPackage,fs-configfs))
 
+define KernelPackage/fs-cramfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Compressed RAM/ROM filesystem support
+  DEPENDS:=+kmod-lib-zlib
+  KCONFIG:= \
+       CONFIG_CRAMFS
+  FILES:=$(LINUX_DIR)/fs/cramfs/cramfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,cramfs)
+endef
+
+define KernelPackage/fs-cramfs/description
+ Kernel module for cramfs support
+endef
+
+$(eval $(call KernelPackage,fs-cramfs))
 
 define KernelPackage/fs-exportfs
   SUBMENU:=$(FS_MENU)
   TITLE:=exportfs kernel server support
   KCONFIG:=CONFIG_EXPORTFS
   FILES=$(LINUX_DIR)/fs/exportfs/exportfs.ko
-  AUTOLOAD:=$(call AutoLoad,20,exportfs)
+  AUTOLOAD:=$(call AutoLoad,20,exportfs,1)
 endef
 
 define KernelPackage/fs-exportfs/description
@@ -111,7 +163,7 @@ define KernelPackage/fs-ext4
        $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
   AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
-  $(call AddDepends/crc16, +!LINUX_3_3:kmod-crypto-hash)
+  $(call AddDepends/crc16, +kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description
@@ -121,6 +173,27 @@ endef
 $(eval $(call KernelPackage,fs-ext4))
 
 
+define KernelPackage/fs-f2fs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=F2FS filesystem support
+  KCONFIG:= \
+       CONFIG_F2FS_FS \
+       CONFIG_F2FS_STAT_FS=y \
+       CONFIG_F2FS_FS_XATTR=y \
+       CONFIG_F2FS_FS_POSIX_ACL=n \
+       CONFIG_F2FS_FS_SECURITY=n \
+       CONFIG_F2FS_CHECK_FS=n
+  FILES:=$(LINUX_DIR)/fs/f2fs/f2fs.ko
+  AUTOLOAD:=$(call AutoLoad,30,f2fs,1)
+endef
+
+define KernelPackage/fs-f2fs/description
+ Kernel module for F2FS filesystem support
+endef
+
+$(eval $(call KernelPackage,fs-f2fs))
+
+
 define KernelPackage/fuse
   SUBMENU:=$(FS_MENU)
   TITLE:=FUSE (Filesystem in Userspace) support
@@ -220,14 +293,15 @@ $(eval $(call KernelPackage,fs-msdos))
 define KernelPackage/fs-nfs
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS filesystem support
-  DEPENDS:=+kmod-fs-nfs-common
+  DEPENDS:=+kmod-fs-nfs-common +kmod-dnsresolver
   KCONFIG:= \
        CONFIG_NFS_FS \
        CONFIG_NFS_USE_LEGACY_DNS=n \
        CONFIG_NFS_USE_NEW_IDMAPPER=n
   FILES:= \
-       $(LINUX_DIR)/fs/nfs/nfs.ko
-  AUTOLOAD:=$(call AutoLoad,40,nfs)
+       $(LINUX_DIR)/fs/nfs/nfs.ko \
+       $(LINUX_DIR)/fs/nfs/nfsv3.ko
+  AUTOLOAD:=$(call AutoLoad,40,nfs nfsv3)
 endef
 
 define KernelPackage/fs-nfs/description
@@ -242,11 +316,13 @@ define KernelPackage/fs-nfs-common
   TITLE:=Common NFS filesystem modules
   KCONFIG:= \
        CONFIG_LOCKD \
-       CONFIG_SUNRPC
+       CONFIG_SUNRPC \
+       CONFIG_GRACE_PERIOD@ge3.18
   FILES:= \
        $(LINUX_DIR)/fs/lockd/lockd.ko \
-       $(LINUX_DIR)/net/sunrpc/sunrpc.ko
-  AUTOLOAD:=$(call AutoLoad,30,sunrpc lockd)
+       $(LINUX_DIR)/net/sunrpc/sunrpc.ko \
+       $(LINUX_DIR)/fs/nfs_common/grace.ko@ge3.18
+  AUTOLOAD:=$(call AutoLoad,30,grace@ge3.18 sunrpc lockd)
 endef
 
 $(eval $(call KernelPackage,fs-nfs-common))
@@ -361,7 +437,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
-  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
+  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
   AUTOLOAD:=$(call AutoLoad,30,xfs,1)
 endef
@@ -371,3 +447,19 @@ define KernelPackage/fs-xfs/description
 endef
 
 $(eval $(call KernelPackage,fs-xfs))
+
+
+define KernelPackage/fs-jfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=JFS filesystem support
+  KCONFIG:=CONFIG_JFS_FS
+  FILES:=$(LINUX_DIR)/fs/jfs/jfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,jfs,1)
+  $(call AddDepends/nls)
+endef
+
+define KernelPackage/fs-jfs/description
+ Kernel module for JFS support
+endef
+
+$(eval $(call KernelPackage,fs-jfs))