kernel: remove kernel module checks/dependencies for 3.14
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / fs.mk
index dd44eb97f9b9c7c66da4af5005819bb34ca81502..ca529ff4244950dafa9298d493a5b8389d013e9b 100644 (file)
@@ -155,6 +155,9 @@ $(eval $(call KernelPackage,fs-exportfs))
 define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
+  DEPENDS := \
+    +kmod-lib-crc16 \
+    +kmod-crypto-hash
   KCONFIG:= \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
@@ -163,7 +166,6 @@ define KernelPackage/fs-ext4
        $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
   AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
-  $(call AddDepends/crc16, +kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description
@@ -317,12 +319,12 @@ define KernelPackage/fs-nfs-common
   KCONFIG:= \
        CONFIG_LOCKD \
        CONFIG_SUNRPC \
-       CONFIG_GRACE_PERIOD@ge3.18
+       CONFIG_GRACE_PERIOD
   FILES:= \
        $(LINUX_DIR)/fs/lockd/lockd.ko \
        $(LINUX_DIR)/net/sunrpc/sunrpc.ko \
-       $(LINUX_DIR)/fs/nfs_common/grace.ko@ge3.18
-  AUTOLOAD:=$(call AutoLoad,30,grace@ge3.18 sunrpc lockd)
+       $(LINUX_DIR)/fs/nfs_common/grace.ko
+  AUTOLOAD:=$(call AutoLoad,30,grace sunrpc lockd)
 endef
 
 $(eval $(call KernelPackage,fs-nfs-common))
@@ -437,7 +439,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
-  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
+  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
   AUTOLOAD:=$(call AutoLoad,30,xfs,1)
 endef