kernel: fix kmod-usb2-omap usb module
[openwrt/svn-archive/archive.git] / package / kernel / linux / modules / usb.mk
index e3d7165f47e3a51369a338734f75518c06a202f3..38b75a32a9332576d879d6681074ae3e88fb64f1 100644 (file)
@@ -150,11 +150,11 @@ define KernelPackage/usb-phy-omap-usb2
   TITLE:=Support for OMAP2 USB PHY
   KCONFIG:= \
        CONFIG_OMAP_USB2 \
-       CONFIG_OMAP_CONTROL_USB
+       CONFIG_OMAP_CONTROL_PHY
   DEPENDS:=@TARGET_omap
   FILES:= \
        $(LINUX_DIR)/drivers/phy/phy-omap-usb2.ko \
-       $(LINUX_DIR)/drivers/usb/phy/phy-omap-control.ko
+       $(LINUX_DIR)/drivers/phy/phy-omap-control.ko
   AUTOLOAD:=$(call AutoLoad,45,phy-omap-control phy-omap-usb2)
   $(call AddDepends/usb)
 endef
@@ -389,7 +389,9 @@ $(eval $(call KernelPackage,usb2-fsl))
 define KernelPackage/usb2-omap
   TITLE:=Support for USB2 for OMAP
   DEPENDS:=@TARGET_omap +kmod-usb-phy-nop +kmod-usb-phy-am335x +kmod-usb2
-  KCONFIG:=CONFIG_USB_EHCI_HCD_OMAP
+  KCONFIG:=\
+       CONFIG_MFD_OMAP_USB_HOST=y \
+       CONFIG_USB_EHCI_HCD_OMAP
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-omap.ko
   AUTOLOAD:=$(call AutoLoad,39,ehci-omap)
   $(call AddDepends/usb)
@@ -631,6 +633,78 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+<<<<<<< HEAD
+define KernelPackage/usb-serial-garmin
+  TITLE:=Support for Garmin GPS devices
+  KCONFIG:=CONFIG_USB_SERIAL_GARMIN
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/garmin_gps.ko
+  AUTOLOAD:=$(call AutoProbe,garmin_gps)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-garmin/description
+ Should work with most Garmin GPS devices which have a native USB port.
+endef
+
+$(eval $(call KernelPackage,usb-serial-garmin))
+=======
+define KernelPackage/usb-serial-simple
+  TITLE:=USB Serial Simple (Motorola phone)
+  KCONFIG:=CONFIG_USB_SERIAL_SIMPLE
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/usb-serial-simple.ko
+  AUTOLOAD:=$(call AutoProbe,usb-serial-simple)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-simple/description
+  Kernel support for "very simple devices".
+
+Specifically, it supports:
+       - Suunto ANT+ USB device.
+       - Medtronic CareLink USB device (3.18)
+       - Fundamental Software dongle.
+       - Google USB serial devices (3.19)
+       - HP4x calculators
+       - a number of Motorola phones
+       - Novatel Wireless GPS receivers (3.18)
+       - Siemens USB/MPI adapter.
+       - ViVOtech ViVOpay USB device.
+       - Infineon Modem Flashloader USB interface
+       - ZIO Motherboard USB serial interface
+endef
+
+$(eval $(call KernelPackage,usb-serial-simple))
+>>>>>>> kernel: add usb-serial-simple module
+
+
+define KernelPackage/usb-serial-simple
+  TITLE:=USB Serial Simple (Motorola phone)
+  KCONFIG:=CONFIG_USB_SERIAL_SIMPLE
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/usb-serial-simple.ko
+  AUTOLOAD:=$(call AutoProbe,usb-serial-simple)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-simple/description
+  Kernel support for "very simple devices".
+
+Specifically, it supports:
+       - Suunto ANT+ USB device.
+       - Medtronic CareLink USB device (3.18)
+       - Fundamental Software dongle.
+       - Google USB serial devices (3.19)
+       - HP4x calculators
+       - a number of Motorola phones
+       - Novatel Wireless GPS receivers (3.18)
+       - Siemens USB/MPI adapter.
+       - ViVOtech ViVOpay USB device.
+       - Infineon Modem Flashloader USB interface
+       - ZIO Motherboard USB serial interface
+endef
+
+$(eval $(call KernelPackage,usb-serial-simple))
+
+
 define KernelPackage/usb-serial-ti-usb
   TITLE:=Support for TI USB 3410/5052
   KCONFIG:=CONFIG_USB_SERIAL_TI