mac80211: update to 2014-10-08
[openwrt/svn-archive/archive.git] / package / kernel / mac80211 / patches / 400-ath_move_debug_code.patch
index 901dcb1cd448cfd2c6688c02c30611934b8f3b39..ccd4a3e5015ed6474dd3de40d8d2f2729b902890 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -13,8 +13,8 @@ ath-objs :=  main.o \
+@@ -13,10 +13,10 @@ ath-objs :=        main.o \
                regd.o \
                hw.o \
                key.o \
@@ -9,10 +9,12 @@
                dfs_pri_detector.o
  
 -ath-$(CPTCFG_ATH_DEBUG) += debug.o
+ ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
  ccflags-y += -D__CHECK_ENDIAN__
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
-@@ -280,13 +280,6 @@ void _ath_dbg(struct ath_common *common,
+@@ -300,13 +300,6 @@ void _ath_dbg(struct ath_common *common,
  #endif /* CPTCFG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */