mac80211: update to 2014-10-08
[openwrt/svn-archive/archive.git] / package / kernel / mac80211 / patches / 400-ath_move_debug_code.patch
index a01db3ea9bcf37e6b12e2de429f1214266b869e1..ccd4a3e5015ed6474dd3de40d8d2f2729b902890 100644 (file)
@@ -1,18 +1,20 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -11,7 +11,7 @@ obj-$(CPTCFG_ATH_COMMON)     += ath.o
- ath-objs :=   main.o \
+@@ -13,10 +13,10 @@ ath-objs :=        main.o \
                regd.o \
                hw.o \
--              key.o
-+              key.o \
-+              debug.o
+               key.o \
++              debug.o \
+               dfs_pattern_detector.o \
+               dfs_pri_detector.o
  
 -ath-$(CPTCFG_ATH_DEBUG) += debug.o
+ ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
  ccflags-y += -D__CHECK_ENDIAN__
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
-@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
+@@ -300,13 +300,6 @@ void _ath_dbg(struct ath_common *common,
  #endif /* CPTCFG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */