odhcpd: fix regression in dhcpv6 t1 and t2 calculation
[openwrt/svn-archive/archive.git] / package / kernel / mac80211 / patches / 560-ath9k_pcoem_optional.patch
index bbed4e3d9c5c8a025e0d8cf96faa466ec4058ed3..cc326880d4723af7d4a5577f7c104cb2d9160e9c 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/wireless/ath/ath9k/Kconfig
 +++ b/drivers/net/wireless/ath/ath9k/Kconfig
-@@ -133,6 +133,11 @@ config ATH9K_RFKILL
-         seconds. Turn off to save power, but enable it if you have
-         a platform that can toggle the RF-Kill GPIO.
+@@ -151,6 +151,11 @@ config ATH9K_CHANNEL_CONTEXT
+        for multi-channel concurrency. Enable this if P2P PowerSave support
+        is required.
  
 +config ATH9K_PCOEM
 +      bool "Atheros ath9k support for PC OEM cards" if EXPERT
@@ -14,7 +14,7 @@
         depends on m
 --- a/drivers/net/wireless/ath/ath9k/Makefile
 +++ b/drivers/net/wireless/ath/ath9k/Makefile
-@@ -31,7 +31,6 @@ ath9k_hw-y:= \
+@@ -32,7 +32,6 @@ ath9k_hw-y:= \
                ar5008_phy.o \
                ar9002_calib.o \
                ar9003_calib.o \
                calib.o \
                eeprom.o \
                eeprom_def.o \
-@@ -48,6 +47,8 @@ ath9k_hw-$(CPTCFG_ATH9K_WOW) += ar9003_w
+@@ -50,6 +49,8 @@ ath9k_hw-$(CPTCFG_ATH9K_WOW) += ar9003_w
  ath9k_hw-$(CPTCFG_ATH9K_BTCOEX_SUPPORT) += btcoex.o \
                                           ar9003_mci.o
-+ath9k-hw-$(CPTCFG_ATH9K_PCOEM) += ar9003_rtt.o
++ath9k_hw-$(CPTCFG_ATH9K_PCOEM) += ar9003_rtt.o
 +
obj-$(CPTCFG_ATH9K_HW) += ath9k_hw.o
ath9k_hw-$(CPTCFG_ATH9K_DYNACK) += dynack.o
  
- obj-$(CPTCFG_ATH9K_COMMON) += ath9k_common.o
+ obj-$(CPTCFG_ATH9K_HW) += ath9k_hw.o
 --- a/drivers/net/wireless/ath/ath9k/ar9003_rtt.h
 +++ b/drivers/net/wireless/ath/ath9k/ar9003_rtt.h
 @@ -17,6 +17,7 @@
@@ -84,7 +84,7 @@
  #endif
 --- a/drivers/net/wireless/ath/ath9k/hw.h
 +++ b/drivers/net/wireless/ath/ath9k/hw.h
-@@ -244,13 +244,20 @@ enum ath9k_hw_caps {
+@@ -245,13 +245,20 @@ enum ath9k_hw_caps {
        ATH9K_HW_CAP_2GHZ                       = BIT(11),
        ATH9K_HW_CAP_5GHZ                       = BIT(12),
        ATH9K_HW_CAP_APM                        = BIT(13),
  /*
 --- a/drivers/net/wireless/ath/ath9k/init.c
 +++ b/drivers/net/wireless/ath/ath9k/init.c
-@@ -355,6 +355,9 @@ static void ath9k_init_pcoem_platform(st
+@@ -362,6 +362,9 @@ static void ath9k_init_pcoem_platform(st
        struct ath9k_hw_capabilities *pCap = &ah->caps;
        struct ath_common *common = ath9k_hw_common(ah);
  
  
 --- a/drivers/net/wireless/ath/ath9k/pci.c
 +++ b/drivers/net/wireless/ath/ath9k/pci.c
-@@ -30,6 +30,7 @@ static DEFINE_PCI_DEVICE_TABLE(ath_pci_i
+@@ -30,6 +30,7 @@ static const struct pci_device_id ath_pc
        { PCI_VDEVICE(ATHEROS, 0x0029) }, /* PCI   */
        { PCI_VDEVICE(ATHEROS, 0x002A) }, /* PCI-E */
  
        { PCI_DEVICE_SUB(PCI_VENDOR_ID_ATHEROS,
                         0x002A,
                         PCI_VENDOR_ID_AZWAVE,
-@@ -82,6 +83,7 @@ static DEFINE_PCI_DEVICE_TABLE(ath_pci_i
+@@ -82,6 +83,7 @@ static const struct pci_device_id ath_pc
                         PCI_VENDOR_ID_AZWAVE,
                         0x2C37),
          .driver_data = ATH9K_PCI_BT_ANT_DIV },
  
        { PCI_VDEVICE(ATHEROS, 0x002B) }, /* PCI-E */
        { PCI_VDEVICE(ATHEROS, 0x002C) }, /* PCI-E 802.11n bonded out */
-@@ -102,6 +104,7 @@ static DEFINE_PCI_DEVICE_TABLE(ath_pci_i
+@@ -102,6 +104,7 @@ static const struct pci_device_id ath_pc
  
        { PCI_VDEVICE(ATHEROS, 0x0030) }, /* PCI-E  AR9300 */
  
        /* PCI-E CUS198 */
        { PCI_DEVICE_SUB(PCI_VENDOR_ID_ATHEROS,
                         0x0032,
-@@ -294,10 +297,12 @@ static DEFINE_PCI_DEVICE_TABLE(ath_pci_i
+@@ -294,10 +297,12 @@ static const struct pci_device_id ath_pc
                         PCI_VENDOR_ID_ASUSTEK,
                         0x850D),
          .driver_data = ATH9K_PCI_NO_PLL_PWRSAVE },
        /* PCI-E CUS217 */
        { PCI_DEVICE_SUB(PCI_VENDOR_ID_ATHEROS,
                         0x0034,
-@@ -657,6 +662,7 @@ static DEFINE_PCI_DEVICE_TABLE(ath_pci_i
+@@ -657,6 +662,7 @@ static const struct pci_device_id ath_pc
        /* PCI-E AR9565 (WB335) */
        { PCI_VDEVICE(ATHEROS, 0x0036),
          .driver_data = ATH9K_PCI_BT_ANT_DIV },
        { 0 }
 --- a/drivers/net/wireless/ath/ath9k/reg.h
 +++ b/drivers/net/wireless/ath/ath9k/reg.h
-@@ -891,10 +891,21 @@
+@@ -892,10 +892,21 @@
        (AR_SREV_9330((_ah)) && \
         ((_ah)->hw_version.macRev == AR_SREV_REVISION_9330_12))
  
         ((_ah)->hw_version.macRev >= AR_SREV_REVISION_9485_11))
  #define AR_SREV_9485_OR_LATER(_ah) \
        (((_ah)->hw_version.macVersion >= AR_SREV_VERSION_9485))
-@@ -910,34 +921,30 @@
+@@ -915,34 +926,30 @@
      (AR_SREV_9285_12_OR_LATER(_ah) && \
       ((REG_READ(_ah, AR_AN_SYNTH9) & 0x7) == 0x1))
  
  #define AR_SREV_9550(_ah) \
 --- a/.local-symbols
 +++ b/.local-symbols
-@@ -129,6 +129,7 @@ ATH9K_HW=
+@@ -124,6 +124,7 @@ ATH9K_HW=
  ATH9K_COMMON=
  ATH9K_DFS_DEBUGFS=
  ATH9K_BTCOEX_SUPPORT=