[package] allow gemini target to use rfkill
[openwrt/svn-archive/archive.git] / package / kernel / modules / 001-depends.mk
index 5bba0870ee78305ccef7a6bd712331c19383b2e5..602775c0157a5a0e0ac187005914fd84b17bc7c1 100644 (file)
@@ -8,11 +8,11 @@
 # XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
 
 define SetDepends/crc16
-  DEPENDS:= @!(LINUX_2_4||TARGET_xburst)
+  DEPENDS:= @!TARGET_xburst
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!(LINUX_2_4||TARGET_xburst):kmod-crc16 $(1)
+  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
 endef
 
 
@@ -36,7 +36,7 @@ endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
 endef
 
 define AddDepends/rfkill