[kernel] add lm92 kernel module
[openwrt/svn-archive/archive.git] / package / kernel / modules / 001-depends.mk
index 5cb34120813d85457ed2e8d245105efcc76738eb..e0af73570516822a658d60b21d8e7acd487eab31 100644 (file)
@@ -1,45 +1,37 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
-endef
-
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16
-endef
-
-
-define SetDepends/hid
-  DEPENDS:= @!TARGET_x86
+  DEPENDS+= +kmod-lib-crc16 $(1)
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid
-
+  DEPENDS+= +kmod-hid $(1)
 endef
 
-
-define SetDepends/input
-  DEPENDS:= @!TARGET_x86
+define AddDepends/input
+  DEPENDS+= +kmod-input-core $(1)
 endef
 
-define AddDepends/input
-  DEPENDS+= +!TARGET_x86:kmod-input-core
+
+define AddDepends/nls
+  DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
 endef
 
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
+endef
+
 
+define AddDepends/rtc
+  DEPENDS+= @RTC_SUPPORT
 endef