[package] modules: fix several typos in block.mk
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index 44fd8c1c0e3de6af8325d6f5463255aae5a6e2be..34ed8c8e1e575ce5b68380aa5ce5bd0c841c49ad 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 BLOCK_MENU:=Block Devices
 
@@ -36,6 +35,22 @@ endef
 $(eval $(call KernelPackage,ata-ahci))
 
 
+define KernelPackage/ata-sil24
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Silicon Image 3124/3132 SATA support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_SATA_SIL24
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,sata_sil24)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support
@@ -70,7 +85,7 @@ $(eval $(call KernelPackage,ata-ixp4xx-cf))
 define KernelPackage/ata-rb532-cf
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=RB532 Compact Flash support
-  DEPENDS:=@TARGET_rb532 kmod-ata-core
+  DEPENDS:=@TARGET_rb532 kmod-ata-core @BROKEN
   KCONFIG:= \
        CONFIG_PATA_PLATFORM \
        CONFIG_PATA_RB532
@@ -131,6 +146,7 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+# XXX: broken on 2.6.28 due to module name/path changes
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
@@ -182,7 +198,11 @@ define KernelPackage/ide-aec62xx
   TITLE:=Acard AEC62xx IDE driver
   DEPENDS:=@PCI_SUPPORT +kmod-ide-core
   KCONFIG:=CONFIG_BLK_DEV_AEC62XX
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),1)
+  FILES:=$(LINUX_DIR)/drivers/ide/aec62xx.$(LINUX_KMOD_SUFFIX)
+else
   FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.$(LINUX_KMOD_SUFFIX)
+endif
   AUTOLOAD:=$(call AutoLoad,30,aec62xx)
 endef
 
@@ -315,3 +335,18 @@ define KernelPackage/aoe/description
 endef
 
 $(eval $(call KernelPackage,aoe))
+
+define KernelPackage/ps3vram
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=PS3 Video RAM Storage Driver
+  DEPENDS:=@TARGET_ps3||TARGET_ps3chk
+  KCONFIG:=CONFIG_PS3_VRAM
+  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
+endef
+
+define KernelPackage/ps3vram/description
+  Kernel support for PS3 Video RAM Storage
+endef
+
+$(eval $(call KernelPackage,ps3vram))