add dependency on rb532 target for its CF module
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index 98e58c5a1b624b46092a04c376370003425ce26d..44fd8c1c0e3de6af8325d6f5463255aae5a6e2be 100644 (file)
@@ -70,7 +70,7 @@ $(eval $(call KernelPackage,ata-ixp4xx-cf))
 define KernelPackage/ata-rb532-cf
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=RB532 Compact Flash support
-  DEPENDS:=kmod-ata-core
+  DEPENDS:=@TARGET_rb532 kmod-ata-core
   KCONFIG:= \
        CONFIG_PATA_PLATFORM \
        CONFIG_PATA_RB532
@@ -300,3 +300,18 @@ define KernelPackage/pata-rb153-cf/description
 endef
 
 $(eval $(call KernelPackage,pata-rb153-cf))
+
+
+define KernelPackage/aoe
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=ATA over Ethernet support
+  KCONFIG:=CONFIG_ATA_OVER_ETH
+  FILES:=$(LINUX_DIR)/drivers/block/aoe/aoe.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,aoe)
+endef
+
+define KernelPackage/aoe/description
+  Kernel support for ATA over Ethernet
+endef
+
+$(eval $(call KernelPackage,aoe))