package/kernel: arc4 needs blkcipher support on 3.6
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index 8af67b37ce46e328b8989cd3e1367e545b12f634..a4288b2a8bd89b7a4c0ed1e4ecf58d1f33a65f99 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax||!TARGET_x86)
+  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax)
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
   AUTOLOAD:=$(call AutoLoad,21,libata,1)
@@ -36,15 +36,17 @@ $(eval $(call KernelPackage,ata-core))
 
 define AddDepends/ata
   SUBMENU:=$(BLOCK_MENU)
-  DEPENDS+=!TARGET_x86:kmod-ata-core $(1)
+  DEPENDS+=kmod-ata-core $(1)
 endef
 
 
 define KernelPackage/ata-ahci
   TITLE:=AHCI Serial ATA support
   KCONFIG:=CONFIG_SATA_AHCI
-  FILES:=$(LINUX_DIR)/drivers/ata/ahci.ko
-  AUTOLOAD:=$(call AutoLoad,41,ahci,1)
+  FILES:= \
+    $(LINUX_DIR)/drivers/ata/ahci.ko \
+    $(LINUX_DIR)/drivers/ata/libahci.ko
+  AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
   $(call AddDepends/ata)
 endef
 
@@ -70,6 +72,21 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-marvell-sata
+  TITLE:=Marvell Serial ATA support
+  KCONFIG:=CONFIG_SATA_MV
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-marvell-sata/description
+ SATA support for marvell chipsets
+endef
+
+$(eval $(call KernelPackage,ata-marvell-sata))
+
+
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV
@@ -146,6 +163,21 @@ endef
 $(eval $(call KernelPackage,ata-sil24))
 
 
+define KernelPackage/ata-sis
+  TITLE:=SIS SATA support
+  KCONFIG:=CONFIG_SATA_SIS
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-sis/description
+ Support for SIS Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sis))
+
+
 define KernelPackage/ata-via-sata
   TITLE:=VIA SATA support
   KCONFIG:=CONFIG_SATA_VIA
@@ -201,6 +233,150 @@ endef
 $(eval $(call KernelPackage,dm))
 
 
+define KernelPackage/md-mod
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=MD RAID
+  KCONFIG:= \
+       CONFIG_MD=y \
+       CONFIG_BLK_DEV_MD=m \
+       CONFIG_MD_AUTODETECT=y \
+       CONFIG_MD_FAULTY=n
+  FILES:=$(LINUX_DIR)/drivers/md/md-mod.ko
+  AUTOLOAD:=$(call AutoLoad,27,md-mod)
+endef
+
+define KernelPackage/md-mod/description
+ Kernel RAID md module (md-mod.ko).
+ You will need to select at least one RAID level module below.
+endef
+
+$(eval $(call KernelPackage,md-mod))
+
+
+define KernelPackage/md/Depends
+  SUBMENU:=$(BLOCK_MENU)
+  DEPENDS:=kmod-md-mod $(1)
+endef
+
+
+define KernelPackage/md-linear
+$(call KernelPackage/md/Depends,)
+  TITLE:=RAID Linear Module
+  KCONFIG:=CONFIG_MD_LINEAR
+  FILES:=$(LINUX_DIR)/drivers/md/linear.ko
+  AUTOLOAD:=$(call AutoLoad,28,linear)
+endef
+
+define KernelPackage/md-linear/description
+ RAID "Linear" or "Append" driver module (linear.ko)
+endef
+
+$(eval $(call KernelPackage,md-linear))
+
+
+define KernelPackage/md-raid0
+$(call KernelPackage/md/Depends,)
+  TITLE:=RAID0 Module
+  KCONFIG:=CONFIG_MD_RAID0
+  FILES:=$(LINUX_DIR)/drivers/md/raid0.ko
+  AUTOLOAD:=$(call AutoLoad,28,raid0)
+endef
+
+define KernelPackage/md-raid0/description
+ RAID Level 0 (Striping) driver module (raid0.ko)
+endef
+
+$(eval $(call KernelPackage,md-raid0))
+
+
+define KernelPackage/md-raid1
+$(call KernelPackage/md/Depends,)
+  TITLE:=RAID1 Module
+  KCONFIG:=CONFIG_MD_RAID1
+  FILES:=$(LINUX_DIR)/drivers/md/raid1.ko
+  AUTOLOAD:=$(call AutoLoad,28,raid1)
+endef
+
+define KernelPackage/md-raid1/description
+ RAID Level 1 (Mirroring) driver (raid1.ko)
+endef
+
+$(eval $(call KernelPackage,md-raid1))
+
+
+define KernelPackage/md-raid10
+$(call KernelPackage/md/Depends,)
+  TITLE:=RAID10 Module
+  KCONFIG:=CONFIG_MD_RAID10
+  FILES:=$(LINUX_DIR)/drivers/md/raid10.ko
+  AUTOLOAD:=$(call AutoLoad,28,raid10)
+endef
+
+define KernelPackage/md-raid10/description
+ RAID Level 10 (Mirroring+Striping) driver module (raid10.ko)
+endef
+
+$(eval $(call KernelPackage,md-raid10))
+
+
+define KernelPackage/md-raid456
+$(call KernelPackage/md/Depends,)
+  TITLE:=RAID Level 456 Driver
+  KCONFIG:= \
+       CONFIG_XOR_BLOCKS \
+       CONFIG_ASYNC_CORE \
+       CONFIG_ASYNC_MEMCPY \
+       CONFIG_ASYNC_XOR \
+       CONFIG_ASYNC_PQ \
+       CONFIG_ASYNC_RAID6_RECOV \
+       CONFIG_ASYNC_RAID6_TEST=n \
+       CONFIG_MD_RAID6_PQ \
+       CONFIG_MD_RAID456 \
+       CONFIG_MULTICORE_RAID456=n
+  FILES:= \
+       $(LINUX_DIR)/crypto/xor.ko \
+       $(LINUX_DIR)/crypto/async_tx/async_tx.ko \
+       $(LINUX_DIR)/crypto/async_tx/async_memcpy.ko \
+       $(LINUX_DIR)/crypto/async_tx/async_xor.ko \
+       $(LINUX_DIR)/crypto/async_tx/async_pq.ko \
+       $(LINUX_DIR)/crypto/async_tx/async_raid6_recov.ko \
+       $(LINUX_DIR)/drivers/md/raid456.ko \
+       $(LINUX_DIR)/lib/raid6/raid6_pq.ko
+  AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor raid6_pq async_pq async_raid6_recov raid456)
+endef
+
+define KernelPackage/md-raid456/description
+ RAID Level 4,5,6 kernel module (raid456.ko)
+
+ Includes the following modules required by
+ raid456.ko:
+    xor.ko
+    async_tx.ko
+    async_xor.ko
+    async_memcpy.ko
+    async_pq.ko
+    async_raid5_recov.ko
+    raid6_pq.ko 
+endef
+
+$(eval $(call KernelPackage,md-raid456))
+
+
+define KernelPackage/md-multipath
+$(call KernelPackage/md/Depends,)
+  TITLE:=MD Multipath Module
+  KCONFIG:=CONFIG_MD_MULTIPATH
+  FILES:=$(LINUX_DIR)/drivers/md/multipath.ko
+  AUTOLOAD:=$(call AutoLoad,29,multipath)
+endef
+
+define KernelPackage/md-multipath/description
+ Multipath driver module (multipath.ko)
+endef
+
+$(eval $(call KernelPackage,md-multipath))
+
+
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
@@ -212,27 +388,14 @@ define KernelPackage/ide-core
        CONFIG_IDE_GD \
        CONFIG_IDE_GD_ATA=y \
        CONFIG_IDE_GD_ATAPI=n \
+       CONFIG_IDEPCI_PCIBUS_ORDER=y \
        CONFIG_BLK_DEV_IDEDMA_PCI=y \
        CONFIG_BLK_DEV_IDEPCI=y
   FILES:= \
-       $(LINUX_DIR)/drivers/ide/ide-core.ko
+       $(LINUX_DIR)/drivers/ide/ide-core.ko \
+       $(LINUX_DIR)/drivers/ide/ide-gd_mod.ko
   AUTOLOAD:= \
-       $(call AutoLoad,20,ide-core,1)
-endef
-
-define KernelPackage/ide-core/2.4
-  FILES+= \
-       $(LINUX_DIR)/drivers/ide/ide-detect.ko \
-       $(LINUX_DIR)/drivers/ide/ide-disk.ko
-  AUTOLOAD+= \
-       $(call AutoLoad,35,ide-detect,1) \
-       $(call AutoLoad,40,ide-disk,1)
-endef
-
-define KernelPackage/ide-core/2.6
-  FILES+= \
-       $(LINUX_DIR)/drivers/ide/ide-gd_mod.ko
-  AUTOLOAD+= \
+       $(call AutoLoad,20,ide-core,1) \
        $(call AutoLoad,40,ide-gd_mod,1)
 endef
 
@@ -240,8 +403,7 @@ define KernelPackage/ide-core/description
  Kernel support for IDE, useful for usb mass storage devices (e.g. on WL-HDD)
  Includes:
  - ide-core
- - ide-detect
- - ide-gd_mod (or ide-disk)
+ - ide-gd_mod
 endef
 
 $(eval $(call KernelPackage,ide-core))
@@ -258,23 +420,11 @@ define KernelPackage/ide-generic
   DEPENDS:=@PCI_SUPPORT
   TITLE:=Kernel support for generic PCI IDE chipsets
   KCONFIG:=CONFIG_BLK_DEV_GENERIC
+  FILES:=$(LINUX_DIR)/drivers/ide/ide-pci-generic.ko
+  AUTOLOAD:=$(call AutoLoad,30,ide-pci-generic,1)
   $(call AddDepends/ide)
 endef
 
-define KernelPackage/ide-generic/2.4
-  FILES+= \
-       $(LINUX_DIR)/drivers/ide/pci/generic.ko
-  AUTOLOAD+= \
-       $(call AutoLoad,30,generic,1)
-endef
-
-define KernelPackage/ide-generic/2.6
-  FILES+= \
-       $(LINUX_DIR)/drivers/ide/ide-pci-generic.ko
-  AUTOLOAD+= \
-       $(call AutoLoad,30,ide-pci-generic,1)
-endef
-
 $(eval $(call KernelPackage,ide-generic))
 
 
@@ -299,10 +449,6 @@ define KernelPackage/ide-aec62xx
   $(call AddDepends/ide)
 endef
 
-define KernelPackage/ide-aec62xx/2.4
-  FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.ko
-endef
-
 define KernelPackage/ide-aec62xx/description
  Support for Acard AEC62xx (Artop ATP8xx) IDE controllers.
 endef
@@ -319,10 +465,6 @@ define KernelPackage/ide-pdc202xx
   $(call AddDepends/ide)
 endef
 
-define KernelPackage/ide-pdc202xx/2.4
-  FILES:=$(LINUX_DIR)/drivers/ide/pci/pdc202xx_old.ko
-endef
-
 define KernelPackage/ide-pdc202xx/description
  Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE
  controllers.
@@ -350,7 +492,6 @@ $(eval $(call KernelPackage,ide-it821x))
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SAS Domain Transport Attributes
-  DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
        CONFIG_SCSI_SAS_ATTRS \
        CONFIG_SCSI_SAS_ATA=y \
@@ -390,12 +531,10 @@ define KernelPackage/mvsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Marvell 88SE6440 SAS/SATA driver
   DEPENDS:=@TARGET_x86 +kmod-libsas
-  KCONFIG:=CONFIG_SCSI_MVSAS
-  ifneq ($(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_30),)
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.ko
-  else
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
-  endif
+  KCONFIG:= \
+       CONFIG_SCSI_MVSAS \
+       CONFIG_SCSI_MVSAS_TASKLET=n
+  FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
   AUTOLOAD:=$(call AutoLoad,40,mvsas,1)
 endef
 
@@ -424,7 +563,6 @@ $(eval $(call KernelPackage,nbd))
 define KernelPackage/scsi-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SCSI device support
-  DEPENDS:=@!TARGET_x86
   KCONFIG:= \
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
@@ -440,6 +578,7 @@ $(eval $(call KernelPackage,scsi-core))
 define KernelPackage/scsi-generic
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for SCSI generic
+  DEPENDS:=+kmod-scsi-core
   KCONFIG:= \
        CONFIG_CHR_DEV_SG
   FILES:= \
@@ -448,3 +587,20 @@ define KernelPackage/scsi-generic
 endef
 
 $(eval $(call KernelPackage,scsi-generic))
+
+
+define KernelPackage/scsi-cdrom
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Kernel support for CD / DVD drives
+  DEPENDS:=+kmod-scsi-core
+  KCONFIG:= \
+    CONFIG_BLK_DEV_SR \
+    CONFIG_BLK_DEV_SR_VENDOR=n
+  FILES:= \
+    $(LINUX_DIR)/drivers/cdrom/cdrom.ko \
+    $(LINUX_DIR)/drivers/scsi/sr_mod.ko
+  AUTOLOAD:=$(call AutoLoad,30,cdrom) $(call AutoLoad,45,sr_mod)
+endef
+
+$(eval $(call KernelPackage,scsi-cdrom))
+