package/kernel: arc4 needs blkcipher support on 3.6
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index d9ba4e46609a40ba70cdd3be2edb4d41b53a724b..a4288b2a8bd89b7a4c0ed1e4ecf58d1f33a65f99 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,aoe))
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax||!TARGET_x86)
+  DEPENDS:=@PCI_SUPPORT +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax)
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.ko
   AUTOLOAD:=$(call AutoLoad,21,libata,1)
@@ -36,20 +36,17 @@ $(eval $(call KernelPackage,ata-core))
 
 define AddDepends/ata
   SUBMENU:=$(BLOCK_MENU)
-  DEPENDS+=!TARGET_x86:kmod-ata-core $(1)
+  DEPENDS+=kmod-ata-core $(1)
 endef
 
 
 define KernelPackage/ata-ahci
   TITLE:=AHCI Serial ATA support
   KCONFIG:=CONFIG_SATA_AHCI
-  FILES:=$(LINUX_DIR)/drivers/ata/ahci.ko
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
-    FILES += $(LINUX_DIR)/drivers/ata/libahci.ko
-    AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
-  else
-    AUTOLOAD:=$(call AutoLoad,41,ahci,1)
-  endif
+  FILES:= \
+    $(LINUX_DIR)/drivers/ata/ahci.ko \
+    $(LINUX_DIR)/drivers/ata/libahci.ko
+  AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
   $(call AddDepends/ata)
 endef
 
@@ -75,6 +72,21 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-marvell-sata
+  TITLE:=Marvell Serial ATA support
+  KCONFIG:=CONFIG_SATA_MV
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-marvell-sata/description
+ SATA support for marvell chipsets
+endef
+
+$(eval $(call KernelPackage,ata-marvell-sata))
+
+
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV
@@ -151,6 +163,21 @@ endef
 $(eval $(call KernelPackage,ata-sil24))
 
 
+define KernelPackage/ata-sis
+  TITLE:=SIS SATA support
+  KCONFIG:=CONFIG_SATA_SIS
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-sis/description
+ Support for SIS Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sis))
+
+
 define KernelPackage/ata-via-sata
   TITLE:=VIA SATA support
   KCONFIG:=CONFIG_SATA_VIA
@@ -235,7 +262,7 @@ endef
 define KernelPackage/md-linear
 $(call KernelPackage/md/Depends,)
   TITLE:=RAID Linear Module
-  KCONFIG:=CONFIG_MD_LINEAR=m
+  KCONFIG:=CONFIG_MD_LINEAR
   FILES:=$(LINUX_DIR)/drivers/md/linear.ko
   AUTOLOAD:=$(call AutoLoad,28,linear)
 endef
@@ -250,7 +277,7 @@ $(eval $(call KernelPackage,md-linear))
 define KernelPackage/md-raid0
 $(call KernelPackage/md/Depends,)
   TITLE:=RAID0 Module
-  KCONFIG:=CONFIG_MD_RAID0=m
+  KCONFIG:=CONFIG_MD_RAID0
   FILES:=$(LINUX_DIR)/drivers/md/raid0.ko
   AUTOLOAD:=$(call AutoLoad,28,raid0)
 endef
@@ -265,7 +292,7 @@ $(eval $(call KernelPackage,md-raid0))
 define KernelPackage/md-raid1
 $(call KernelPackage/md/Depends,)
   TITLE:=RAID1 Module
-  KCONFIG:=CONFIG_MD_RAID1=m
+  KCONFIG:=CONFIG_MD_RAID1
   FILES:=$(LINUX_DIR)/drivers/md/raid1.ko
   AUTOLOAD:=$(call AutoLoad,28,raid1)
 endef
@@ -280,7 +307,7 @@ $(eval $(call KernelPackage,md-raid1))
 define KernelPackage/md-raid10
 $(call KernelPackage/md/Depends,)
   TITLE:=RAID10 Module
-  KCONFIG:=CONFIG_MD_RAID10=m
+  KCONFIG:=CONFIG_MD_RAID10
   FILES:=$(LINUX_DIR)/drivers/md/raid10.ko
   AUTOLOAD:=$(call AutoLoad,28,raid10)
 endef
@@ -296,15 +323,15 @@ define KernelPackage/md-raid456
 $(call KernelPackage/md/Depends,)
   TITLE:=RAID Level 456 Driver
   KCONFIG:= \
-       CONFIG_XOR_BLOCKS=m \
-       CONFIG_ASYNC_CORE=m \
-       CONFIG_ASYNC_MEMCPY=m \
-       CONFIG_ASYNC_XOR=m \
-       CONFIG_ASYNC_PQ=m \
-       CONFIG_ASYNC_RAID6_RECOV=m \
+       CONFIG_XOR_BLOCKS \
+       CONFIG_ASYNC_CORE \
+       CONFIG_ASYNC_MEMCPY \
+       CONFIG_ASYNC_XOR \
+       CONFIG_ASYNC_PQ \
+       CONFIG_ASYNC_RAID6_RECOV \
        CONFIG_ASYNC_RAID6_TEST=n \
-       CONFIG_MD_RAID6_PQ=m \
-       CONFIG_MD_RAID456=m \
+       CONFIG_MD_RAID6_PQ \
+       CONFIG_MD_RAID456 \
        CONFIG_MULTICORE_RAID456=n
   FILES:= \
        $(LINUX_DIR)/crypto/xor.ko \
@@ -313,17 +340,8 @@ $(call KernelPackage/md/Depends,)
        $(LINUX_DIR)/crypto/async_tx/async_xor.ko \
        $(LINUX_DIR)/crypto/async_tx/async_pq.ko \
        $(LINUX_DIR)/crypto/async_tx/async_raid6_recov.ko \
-       $(LINUX_DIR)/drivers/md/raid456.ko
-  # Additional files with kernel-dependent locations or presence
-  # For Linux >= 2.6.36
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)), 1)
-    FILES+= \
+       $(LINUX_DIR)/drivers/md/raid456.ko \
        $(LINUX_DIR)/lib/raid6/raid6_pq.ko
-  # For Linux < 2.6.36
-  else
-    FILES+= \
-       $(LINUX_DIR)/drivers/md/raid6_pq.ko
-  endif
   AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor raid6_pq async_pq async_raid6_recov raid456)
 endef
 
@@ -347,7 +365,7 @@ $(eval $(call KernelPackage,md-raid456))
 define KernelPackage/md-multipath
 $(call KernelPackage/md/Depends,)
   TITLE:=MD Multipath Module
-  KCONFIG:=CONFIG_MD_MULTIPATH=m
+  KCONFIG:=CONFIG_MD_MULTIPATH
   FILES:=$(LINUX_DIR)/drivers/md/multipath.ko
   AUTOLOAD:=$(call AutoLoad,29,multipath)
 endef
@@ -471,74 +489,9 @@ endef
 $(eval $(call KernelPackage,ide-it821x))
 
 
-define KernelPackage/cs5535
-  TITLE:=NSC/AMD CS5535 chipset support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_BLK_DEV_CS5535
-  FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
-  AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
-  $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5535/description
-  Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,cs5535))
-
-
-define KernelPackage/cs5536
-  TITLE:=AMD CS5536 chipset support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_BLK_DEV_CS5536
-  FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
-  AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
-  $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5536/description
-  Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,cs5536))
-
-
-define KernelPackage/pata-cs5535
-  TITLE:=CS5535 PATA support
-  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
-  KCONFIG:=CONFIG_PATA_CS5535
-  FILES=$(LINUX_DIR)/drivers/ata/pata-cs5535.ko
-  AUTOLOAD:=$(call AutoLoad,30,pata-cs5535,1)
-  $(call AddDepends/ata)
-endef
-
-define KernelPackage/cs5535/description
-  Kernel module for the NSC/AMD CS5535 companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5535))
-
-
-define KernelPackage/pata-cs5536
-  TITLE:=CS5536 PATA support
-  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
-  KCONFIG:=CONFIG_PATA_CS5536
-  FILES=$(LINUX_DIR)/drivers/ata/pata-cs5536.ko
-  AUTOLOAD:=$(call AutoLoad,30,pata-cs5536,1)
-  $(call AddDepends/ata)
-endef
-
-define KernelPackage/cs5536/description
-  Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,pata-cs5536))
-
-
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SAS Domain Transport Attributes
-  DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
        CONFIG_SCSI_SAS_ATTRS \
        CONFIG_SCSI_SAS_ATA=y \
@@ -578,12 +531,10 @@ define KernelPackage/mvsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Marvell 88SE6440 SAS/SATA driver
   DEPENDS:=@TARGET_x86 +kmod-libsas
-  KCONFIG:=CONFIG_SCSI_MVSAS
-  ifneq ($(CONFIG_LINUX_2_6_30),)
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.ko
-  else
-       FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
-  endif
+  KCONFIG:= \
+       CONFIG_SCSI_MVSAS \
+       CONFIG_SCSI_MVSAS_TASKLET=n
+  FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
   AUTOLOAD:=$(call AutoLoad,40,mvsas,1)
 endef
 
@@ -612,7 +563,6 @@ $(eval $(call KernelPackage,nbd))
 define KernelPackage/scsi-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SCSI device support
-  DEPENDS:=@!TARGET_x86
   KCONFIG:= \
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
@@ -628,7 +578,7 @@ $(eval $(call KernelPackage,scsi-core))
 define KernelPackage/scsi-generic
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for SCSI generic
-  DEPENDS:=+!TARGET_x86:kmod-scsi-core
+  DEPENDS:=+kmod-scsi-core
   KCONFIG:= \
        CONFIG_CHR_DEV_SG
   FILES:= \
@@ -642,7 +592,7 @@ $(eval $(call KernelPackage,scsi-generic))
 define KernelPackage/scsi-cdrom
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Kernel support for CD / DVD drives
-  DEPENDS:=+!TARGET_x86:kmod-scsi-core
+  DEPENDS:=+kmod-scsi-core
   KCONFIG:= \
     CONFIG_BLK_DEV_SR \
     CONFIG_BLK_DEV_SR_VENDOR=n