Add ps3vram kernel module
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index a7b6ef24154d5317e60287a3fe424f3d92786792..a5a0906e8fd3150a5566128fcdd0c8663d692411 100644 (file)
@@ -320,3 +320,18 @@ define KernelPackage/aoe/description
 endef
 
 $(eval $(call KernelPackage,aoe))
+
+define KernelPackage/ps3vram
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=PS3 Video RAM Storage Driver
+  DEPENDS:=@TARGET_ps3
+  KCONFIG:=CONFIG_PS3_VRAM
+  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
+endef
+
+define KernelPackage/ps3vram/description
+  Kernel support for PS3 Video RAM Storage
+endef
+
+$(eval $(call KernelPackage,ps3vram))