[magicbox] fix the CF driver on 2.6.26.x, and create a package for it
[openwrt/svn-archive/archive.git] / package / kernel / modules / block.mk
index 3f8bd465b33f3a929351f5cc43b4d2123fa03d5f..bf327e1696e2bbff3d722ef07a45f59528ecb429 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -175,6 +175,22 @@ endef
 $(eval $(call KernelPackage,ide-aec62xx))
 
 
+define KernelPackage/ide-magicbox
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Magicbox 2.0 IDE CF driver
+  DEPENDS:=@TARGET_magicbox +kmod-ide-core
+  KCONFIG:=CONFIG_BLK_DEV_MAGICBOX_IDE
+  FILES:=$(LINUX_DIR)/drivers/ide/ppc/magicbox_ide.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,magicbox_ide)
+endef
+
+define KernelPackage/ide-magicbox/description
+ Support for Magicbox 2.0 onboard CF slot.
+endef
+
+$(eval $(call KernelPackage,ide-magicbox))
+
+
 define KernelPackage/ide-pdc202xx
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Promise PDC202xx IDE driver