remove an obsolete CompareKernelPatchVer call
[openwrt/svn-archive/archive.git] / package / kernel / modules / crypto.mk
index 5cf3b0d3b6b7b252a5e765c8b319d2e14ca8ee39..aaa9d534b226af418ccfec47ed49411d07c4a807 100644 (file)
@@ -22,15 +22,14 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
 SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 
 CRYPTO_MODULES = \
-       $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
+       ALGAPI2=crypto_algapi \
        AEAD2=aead \
        $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
        BLKCIPHER2=crypto_blkcipher \
        HASH2=crypto_hash \
        MANAGER2=cryptomgr \
        CBC=cbc \
-       ECB=ecb \
-       DEFLATE=deflate
+       ECB=ecb
 
 crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
 crypto_file=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
@@ -183,6 +182,16 @@ endef
 
 $(eval $(call KernelPackage,crypto-des))
 
+define KernelPackage/crypto-deflate
+  TITLE:=Deflate compression CryptoAPI module
+  KCONFIG:=CONFIG_CRYPTO_DEFLATE
+  FILES:=$(LINUX_DIR)/crypto/deflate.ko
+  AUTOLOAD:=$(call AutoLoad,09,deflate)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-deflate))
+
 
 define KernelPackage/crypto-hmac
   TITLE:=HMAC digest CryptoAPI module