package: kernel: make crypto kmods always visible
[openwrt/svn-archive/archive.git] / package / kernel / modules / crypto.mk
index f9ce8f96da32120c174b8f837a5368b89ab13fa1..c1c8a989875c9e918734bcc743c84fff12a7616a 100644 (file)
@@ -36,7 +36,7 @@ $(eval $(call KernelPackage,crypto-core))
 
 define AddDepends/crypto
   SUBMENU:=$(CRYPTO_MENU)
-  DEPENDS+=kmod-crypto-core $(1)
+  DEPENDS+=+kmod-crypto-core $(1)
 endef
 
 define KernelPackage/crypto-hash
@@ -154,23 +154,6 @@ endef
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
-define KernelPackage/crypto-hw-ixp4xx
-  TITLE:=Intel IXP4xx hardware crypto module
-  DEPENDS:=@TARGET_ixp4xx
-  KCONFIG:= \
-       CONFIG_CRYPTO_DEV_IXP4XX
-  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
-  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
-  $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
-endef
-
-define KernelPackage/crypto-hw-ixp4xx/description
-  Kernel support for the Intel IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ixp4xx))
-
-
 define KernelPackage/crypto-hw-ppc4xx
   TITLE:=AMCC PPC4xx hardware crypto module
   DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
@@ -209,7 +192,7 @@ define KernelPackage/crypto-arc4
   KCONFIG:=CONFIG_CRYPTO_ARC4
   FILES:=$(LINUX_DIR)/crypto/arc4.ko
   AUTOLOAD:=$(call AutoLoad,09,arc4)
-  $(call AddDepends/crypto)
+  $(call AddDepends/crypto,+!LINUX_3_3:kmod-crypto-manager)
 endef
 
 $(eval $(call KernelPackage,crypto-arc4))
@@ -341,6 +324,9 @@ endef
 
 $(eval $(call KernelPackage,crypto-sha1))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+camellia_mod_suffix=_generic
+endif
 
 define KernelPackage/crypto-misc
   TITLE:=Other CryptoAPI modules
@@ -364,7 +350,7 @@ define KernelPackage/crypto-misc
        CONFIG_CRYPTO_WP512
   FILES:= \
        $(LINUX_DIR)/crypto/anubis.ko \
-       $(LINUX_DIR)/crypto/camellia.ko \
+       $(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
        $(LINUX_DIR)/crypto/cast5.ko \
        $(LINUX_DIR)/crypto/cast6.ko \
        $(LINUX_DIR)/crypto/fcrypt.ko \
@@ -488,19 +474,3 @@ define KernelPackage/crypto-mv-cesa
 endef
 
 $(eval $(call KernelPackage,crypto-mv-cesa))
-
-
-define KernelPackage/ocf-ubsec-ssb
-  TITLE:=BCM5365P IPSec Core driver
-  DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf
-  KCONFIG:=CONFIG_OCF_UBSEC_SSB
-  FILES:=$(LINUX_DIR)/crypto/ocf/ubsec_ssb/ubsec_ssb.ko
-  AUTOLOAD:=$(call AutoLoad,10,ubsec_ssb)
-  $(call AddDepends/crypto)
-endef
-
-define KernelPackage/ocf-ubsec-ssb/description
-  This package contains the OCF driver for the BCM5365p IPSec Core
-endef
-
-$(eval $(call KernelPackage,ocf-ubsec-ssb))