package/kernel: arc4 needs blkcipher support on 3.6
[openwrt/svn-archive/archive.git] / package / kernel / modules / fs.mk
index c0df23f5085e4bd1ecc0e7c192a0db1c3381daba..0bc0d55787b6db40c9d5f602f254cffe48e05272 100644 (file)
@@ -25,10 +25,11 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  DEPENDS:=+kmod-libcrc32c +kmod-zlib
+  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib
   KCONFIG:=\
        CONFIG_BTRFS_FS \
-       CONFIG_BTRFS_FS_POSIX_ACL=n
+       CONFIG_BTRFS_FS_POSIX_ACL=n \
+       CONFIG_BTRFS_FS_CHECK_INTEGRITY=n
   FILES:=\
        $(LINUX_DIR)/fs/btrfs/btrfs.ko
   AUTOLOAD:=$(call AutoLoad,30,btrfs,1)
@@ -44,10 +45,20 @@ $(eval $(call KernelPackage,fs-btrfs))
 define KernelPackage/fs-cifs
   SUBMENU:=$(FS_MENU)
   TITLE:=CIFS support
-  KCONFIG:=CONFIG_CIFS
+  KCONFIG:= \
+       CONFIG_CIFS \
+       CONFIG_CIFS_DFS_UPCALL=n \
+       CONFIG_CIFS_UPCALL=n
   FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
   AUTOLOAD:=$(call AutoLoad,30,cifs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
+  DEPENDS+= \
+    +kmod-crypto-arc4 \
+    +kmod-crypto-hmac \
+    +kmod-crypto-md5 \
+    +kmod-crypto-md4 \
+    +kmod-crypto-des \
+    +kmod-crypto-ecb
 endef
 
 define KernelPackage/fs-cifs/description
@@ -72,53 +83,17 @@ endef
 $(eval $(call KernelPackage,fs-exportfs))
 
 
-define KernelPackage/fs-ext2
-  SUBMENU:=$(FS_MENU)
-  TITLE:=EXT2 filesystem support
-  KCONFIG:=CONFIG_EXT2_FS
-  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
-  FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
-  AUTOLOAD:=$(call AutoLoad,32,ext2,1)
-endef
-
-define KernelPackage/fs-ext2/description
- Kernel module for EXT2 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext2,1))
-
-
-define KernelPackage/fs-ext3
-  SUBMENU:=$(FS_MENU)
-  TITLE:=EXT3 filesystem support
-  KCONFIG:= \
-       CONFIG_EXT3_FS \
-       CONFIG_JBD
-  DEPENDS:=$(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache) @LINUX_2_6_30||LINUX_2_6_31
-  FILES:= \
-       $(LINUX_DIR)/fs/ext3/ext3.ko \
-       $(LINUX_DIR)/fs/jbd/jbd.ko
-  AUTOLOAD:=$(call AutoLoad,31,jbd ext3,1)
-endef
-
-define KernelPackage/fs-ext3/description
- Kernel module for EXT3 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext3))
-
-
 define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
   KCONFIG:= \
        CONFIG_EXT4_FS \
        CONFIG_JBD2
-  DEPENDS:= $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
   FILES:= \
        $(LINUX_DIR)/fs/ext4/ext4.ko \
-       $(LINUX_DIR)/fs/jbd2/jbd2.ko
-  AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4,1)
+       $(LINUX_DIR)/fs/jbd2/jbd2.ko \
+       $(LINUX_DIR)/fs/mbcache.ko
+  AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
   $(call AddDepends/crc16)
 endef
 
@@ -129,13 +104,28 @@ endef
 $(eval $(call KernelPackage,fs-ext4))
 
 
+define KernelPackage/fuse
+  SUBMENU:=$(FS_MENU)
+  TITLE:=FUSE (Filesystem in Userspace) support
+  KCONFIG:= CONFIG_FUSE_FS
+  FILES:=$(LINUX_DIR)/fs/fuse/fuse.ko
+  AUTOLOAD:=$(call AutoLoad,80,fuse)
+endef
+
+define KernelPackage/fuse/description
+ Kernel module for userspace filesystem support
+endef
+
+$(eval $(call KernelPackage,fuse))
+
+
 define KernelPackage/fs-hfs
   SUBMENU:=$(FS_MENU)
   TITLE:=HFS+ filesystem support
   KCONFIG:=CONFIG_HFS_FS
   FILES:=$(LINUX_DIR)/fs/hfs/hfs.ko
   AUTOLOAD:=$(call AutoLoad,30,hfs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-hfs/description
@@ -151,7 +141,7 @@ define KernelPackage/fs-hfsplus
   KCONFIG:=CONFIG_HFSPLUS_FS
   FILES:=$(LINUX_DIR)/fs/hfsplus/hfsplus.ko
   AUTOLOAD:=$(call AutoLoad,30,hfsplus)
-$(call AddDepends/nls,utf8)
+  $(call AddDepends/nls,utf8)
 endef
 
 define KernelPackage/fs-hfsplus/description
@@ -167,7 +157,7 @@ define KernelPackage/fs-isofs
   KCONFIG:=CONFIG_ISO9660_FS CONFIG_JOLIET=y CONFIG_ZISOFS=n
   FILES:=$(LINUX_DIR)/fs/isofs/isofs.ko
   AUTOLOAD:=$(call AutoLoad,30,isofs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-isofs/description
@@ -177,25 +167,6 @@ endef
 $(eval $(call KernelPackage,fs-isofs))
 
 
-define KernelPackage/fs-mbcache
-  SUBMENU:=$(FS_MENU)
-  TITLE:=mbcache (used by ext2/ext3/ext4)
-  KCONFIG:=CONFIG_FS_MBCACHE
-  ifneq ($(CONFIG_FS_MBCACHE),)
-    FILES:=$(LINUX_DIR)/fs/mbcache.ko
-    AUTOLOAD:=$(call AutoLoad,20,mbcache,1)
-  endif
-endef
-
-define KernelPackage/fs-mbcache/description
- Meta Block cache used by ext2/ext3
- This package will only be installed if extended attributes 
- are enabled for ext2/ext3
-endef
-
-$(eval $(call KernelPackage,fs-mbcache))
-
-
 define KernelPackage/fs-minix
   SUBMENU:=$(FS_MENU)
   TITLE:=Minix filesystem support
@@ -217,11 +188,7 @@ define KernelPackage/fs-msdos
   KCONFIG:=CONFIG_MSDOS_FS
   FILES:=$(LINUX_DIR)/fs/fat/msdos.ko
   AUTOLOAD:=$(call AutoLoad,40,msdos)
-$(call AddDepends/nls)
-endef
-
-define KernelPackage/fs-msdos/2.4
-  FILES:=$(LINUX_DIR)/fs/msdos/msdos.ko
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-msdos/description
@@ -236,7 +203,9 @@ define KernelPackage/fs-nfs
   TITLE:=NFS filesystem support
   DEPENDS:=+kmod-fs-nfs-common
   KCONFIG:= \
-       CONFIG_NFS_FS
+       CONFIG_NFS_FS \
+       CONFIG_NFS_USE_LEGACY_DNS=n \
+       CONFIG_NFS_USE_NEW_IDMAPPER=n
   FILES:= \
        $(LINUX_DIR)/fs/nfs/nfs.ko
   AUTOLOAD:=$(call AutoLoad,40,nfs)
@@ -287,7 +256,9 @@ define KernelPackage/fs-nfsd
   SUBMENU:=$(FS_MENU)
   TITLE:=NFS kernel server support
   DEPENDS:=+kmod-fs-nfs-common +kmod-fs-exportfs
-  KCONFIG:=CONFIG_NFSD
+  KCONFIG:= \
+       CONFIG_NFSD \
+       CONFIG_NFSD_FAULT_INJECTION=n
   FILES:=$(LINUX_DIR)/fs/nfsd/nfsd.ko
   AUTOLOAD:=$(call AutoLoad,40,nfsd)
 endef
@@ -305,7 +276,7 @@ define KernelPackage/fs-ntfs
   KCONFIG:=CONFIG_NTFS_FS
   FILES:=$(LINUX_DIR)/fs/ntfs/ntfs.ko
   AUTOLOAD:=$(call AutoLoad,30,ntfs)
-$(call AddDepends/nls)
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-ntfs/description
@@ -336,7 +307,8 @@ define KernelPackage/fs-udf
   KCONFIG:=CONFIG_UDF_FS
   FILES:=$(LINUX_DIR)/fs/udf/udf.ko
   AUTOLOAD:=$(call AutoLoad,30,udf)
-$(call AddDepends/nls)
+  DEPENDS:=+kmod-lib-crc-itu-t
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-udf/description
@@ -356,13 +328,7 @@ define KernelPackage/fs-vfat
        $(LINUX_DIR)/fs/fat/fat.ko \
        $(LINUX_DIR)/fs/fat/vfat.ko
   AUTOLOAD:=$(call AutoLoad,30,fat vfat)
-$(call AddDepends/nls)
-endef
-
-define KernelPackage/fs-vfat/2.4
-  FILES:= \
-       $(LINUX_DIR)/fs/fat/fat.ko \
-       $(LINUX_DIR)/fs/vfat/vfat.ko
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-vfat/description
@@ -376,7 +342,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
-  DEPENDS:= +kmod-fs-exportfs
+  DEPENDS:= +kmod-fs-exportfs @!avr32
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
   AUTOLOAD:=$(call AutoLoad,30,xfs,1)
 endef