add LM77 sensors support (closes: #2419)
[openwrt/svn-archive/archive.git] / package / kernel / modules / hwmon.mk
index 753c455754570ab549a1174193e96f5136659d4e..3dd3f4ceb6a8d3bbd8dfa2967556905906f42215 100644 (file)
@@ -29,13 +29,29 @@ endef
 $(eval $(call KernelPackage,hwmon-core))
 
 
 $(eval $(call KernelPackage,hwmon-core))
 
 
+define KernelPackage/hwmon-lm77
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=LM77 monitoring support
+  DEPENDS:=kmod-hwmon-core
+  KCONFIG:=CONFIG_SENSORS_LM77
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,lm77)
+endef
+define KernelPackage/hwmon-lm77/description
+ Kernel module for LM77 thermal monitor chip 
+endef
+
+$(eval $(call KernelPackage,hwmon-lm77))
+
+
 define KernelPackage/hwmon-pc87360
   SUBMENU:=$(HWMON_MENU)
   TITLE:=PC87360 monitoring support
 define KernelPackage/hwmon-pc87360
   SUBMENU:=$(HWMON_MENU)
   TITLE:=PC87360 monitoring support
+  DEPENDS:=kmod-hwmon-core
   KCONFIG:=CONFIG_SENSORS_PC87360
   FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,pc87360)
   KCONFIG:=CONFIG_SENSORS_PC87360
   FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,pc87360)
-  DEPENDS:=kmod-hwmon-core
 endef
 
 define KernelPackage/hwmon-pc87360/description
 endef
 
 define KernelPackage/hwmon-pc87360/description