package: kernel/modules: package module for MAC-VLAN support
[openwrt/svn-archive/archive.git] / package / kernel / modules / hwmon.mk
index 8ecf6cc8a91367d004e8a28fb33ed2978feb52be..f259a7af93a455a21ebff453a102a6fa01ece528 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 HWMON_MENU:=Hardware Monitoring Support
 
@@ -27,21 +26,51 @@ endef
 $(eval $(call KernelPackage,hwmon-core))
 
 
+define KernelPackage/hwmon-lm75
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=LM75 monitoring support
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+  KCONFIG:=CONFIG_SENSORS_LM75
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,lm75)
+endef
+
+define KernelPackage/hwmon-lm75/description
+ Kernel module for lm75 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm75))
+
+
 define KernelPackage/hwmon-lm77
   SUBMENU:=$(HWMON_MENU)
   TITLE:=LM77 monitoring support
-  DEPENDS:=kmod-hwmon-core kmod-i2c-core
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
   KCONFIG:=CONFIG_SENSORS_LM77
   FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,lm77)
 endef
+
 define KernelPackage/hwmon-lm77/description
- Kernel module for LM77 thermal monitor chip 
+ Kernel module for LM77 thermal monitor chip
 endef
 
 $(eval $(call KernelPackage,hwmon-lm77))
 
+define KernelPackage/hwmon-lm90
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=LM90 monitoring support
+  DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+  KCONFIG:=CONFIG_SENSORS_LM90
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,lm90)
+endef
+
+define KernelPackage/hwmon-lm90/description
+ Kernel module for LM90 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm90))
 
 define KernelPackage/hwmon-pc87360
   SUBMENU:=$(HWMON_MENU)
@@ -62,3 +91,21 @@ endef
 
 $(eval $(call KernelPackage,hwmon-pc87360))
 
+define KernelPackage/hwmon-w83627hf
+  SUBMENU:=$(HWMON_MENU)
+  TITLE:=Winbond W83627HF monitoring support
+  DEPENDS:=kmod-hwmon-core @TARGET_x86||TARGET_rdc
+  KCONFIG:= \
+       CONFIG_SENSORS_W83627HF \
+       CONFIG_HWMON_VID
+  FILES:= \
+       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/hwmon/w83627hf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627h)
+endef
+
+define KernelPacakge/hwmon-w83627hf/description
+  Kernel module for the Winbond W83627HF chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-w83627hf))