get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/svn-archive/archive.git] / package / kernel / modules / i2c.mk
index c02672f4398c552fedae2c01149c5d4bcfeebeea..444cc874f57ca332e23051941373e3663f8ac6bd 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id $
 
 I2C_MENU:=I2C support
 
@@ -79,7 +78,7 @@ $(eval $(call KernelPackage,i2c-algo-pcf))
 define KernelPackage/i2c-gpio
   SUBMENU:=$(I2C_MENU)
   TITLE:=GPIO-based bitbanging I2C
-  DEPENDS:=kmod-i2c-core +kmod-i2c-algo-bit
+  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-algo-bit
   KCONFIG:=CONFIG_I2C_GPIO
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,59,i2c-gpio)
@@ -93,27 +92,13 @@ endef
 $(eval $(call KernelPackage,i2c-gpio))
 
 
-define KernelPackage/i2c-gpio-custom
-  SUBMENU:=$(I2C_MENU)
-  TITLE:=Custom GPIO-based I2C device
-  DEPENDS:=@TARGET_adm5120 kmod-i2c-core +kmod-i2c-gpio
-  KCONFIG:=CONFIG_I2C_GPIO_CUSTOM
-  FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio-custom.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,58,i2c-gpio-custom)
-endef
-
-define KernelPackage/i2c-gpio-custom/description
- Kernel module for register a custom i2c-gpio platform device.
-endef
-
-$(eval $(call KernelPackage,i2c-gpio-custom))
-
-
 define KernelPackage/i2c-scx200
   SUBMENU:=$(I2C_MENU)
   TITLE:=Geode SCx200 I2C using GPIO pins
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 kmod-i2c-core +kmod-i2c-algo-bit
-  KCONFIG:=CONFIG_SCx200_I2C
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
+  KCONFIG:=CONFIG_SCx200_I2C \
+       CONFIG_SCx200_I2C_SCL=12 \
+       CONFIG_SCx200_I2C_SDA=13
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/scx200_i2c.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,59,scx200_i2c)
 endef
@@ -128,14 +113,14 @@ $(eval $(call KernelPackage,i2c-scx200))
 define KernelPackage/i2c-scx200-acb
   SUBMENU:=$(I2C_MENU)
   TITLE:=Geode SCx200 ACCESS.bus support
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 kmod-i2c-core +kmod-i2c-algo-bit
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
   KCONFIG:=CONFIG_SCx200_ACB
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/scx200_acb.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,59,scx200_acb)
 endef
 
 define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200 
+ Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
  and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
 endef