[kernel] fix xen pci module, partially fixes #11970
[openwrt/svn-archive/archive.git] / package / kernel / modules / i2c.mk
index 50501cf4ba5c28be945729e7f184158dddaf2ac6..d0ebfccfc7007982c340f5a7bce7f0b422cbde41 100644 (file)
@@ -101,41 +101,6 @@ endef
 
 $(eval $(call KernelPackage,i2c-gpio))
 
-I2C_SCX200_MODULES:=\
-  CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
-
-define KernelPackage/i2c-scx200
-  $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
-  TITLE:=Geode SCx200 I2C using GPIO pins
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-  KCONFIG+= \
-       CONFIG_SCx200_I2C_SCL=12 \
-       CONFIG_SCx200_I2C_SDA=13
-endef
-
-define KernelPackage/i2c-scx200/description
- Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200))
-
-
-I2C_SCX200_ACB_MODULES:=\
-  CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
-
-define KernelPackage/i2c-scx200-acb
-  $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
-  TITLE:=Geode SCx200 ACCESS.bus support
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-endef
-
-define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
- and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200-acb))
-
 
 OF_I2C_MODULES:=\
   CONFIG_OF_I2C:drivers/of/of_i2c
@@ -201,37 +166,6 @@ endef
 $(eval $(call KernelPackage,i2c-mv64xxx))
 
 
-I2C_AT91_MODULES:=\
-  CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91
-
-define KernelPackage/at91-i2c
-  $(call i2c_defaults,$(I2C_AT91_MODULES),55)
-  TITLE:=I2C (TWI) master driver for Atmel AT91
-  DEPENDS:=@TARGET_at91 +kmod-i2c-core
-endef
-
-define KernelPackage/at91-i2c/description
- Kernel module to use the I2C (TWI) master driver for Atmel AT91
-endef
-
-$(eval $(call KernelPackage,at91-i2c))
-
-I2C_OCTEON_MODULES:=\
-  CONFIG_I2C_OCTEON:drivers/i2c/busses/i2c-octeon
-
-define KernelPackage/octeon-i2c
-  $(call i2c_defaults,$(I2C_OCTEON_MODULES),59)
-  TITLE:=I2C master driver for Cavium Octeon
-  DEPENDS:=@TARGET_octeon +kmod-i2c-core
-endef
-
-define KernelPackage/octeon-i2c/description
-  Kernel module to use the I2C master driver on Cavium Octeon
-endef
-
-$(eval $(call KernelPackage,octeon-i2c))
-
-
 I2C_TINY_USB_MODULES:= \
   CONFIG_I2C_TINY_USB:drivers/i2c/busses/i2c-tiny-usb