[package] kernel: added GPIO driver for CS5535/CS5536 companion chip. Thanks Markus...
[openwrt/svn-archive/archive.git] / package / kernel / modules / i2c.mk
index 2a41ab3bca3770648a441f5a0f570fed6c10c9d3..eaf3667a4d8a239201af2dee45edb895c99a19ac 100644 (file)
@@ -79,7 +79,7 @@ $(eval $(call KernelPackage,i2c-algo-pcf))
 define KernelPackage/i2c-gpio
   SUBMENU:=$(I2C_MENU)
   TITLE:=GPIO-based bitbanging I2C
 define KernelPackage/i2c-gpio
   SUBMENU:=$(I2C_MENU)
   TITLE:=GPIO-based bitbanging I2C
-  DEPENDS:=kmod-i2c-core +kmod-i2c-algo-bit
+  DEPENDS:=@GPIO_SUPPORT kmod-i2c-core +kmod-i2c-algo-bit
   KCONFIG:=CONFIG_I2C_GPIO
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,59,i2c-gpio)
   KCONFIG:=CONFIG_I2C_GPIO
   FILES:=$(LINUX_DIR)/drivers/i2c/busses/i2c-gpio.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,59,i2c-gpio)
@@ -119,7 +119,7 @@ define KernelPackage/i2c-scx200-acb
 endef
 
 define KernelPackage/i2c-scx200-acb/description
 endef
 
 define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200 
+ Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
  and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
 endef
 
  and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
 endef