Revert "[kernel] solos-pci: Depend on soloscli, just like mac80211 depends on iw...
[openwrt/svn-archive/archive.git] / package / kernel / modules / netdevices.mk
index d9e9a3c7ed3d785d1b3167afeda16a67d4372a8b..1290b7f5fa9f37fd477863aa491b717606d8f5e9 100644 (file)
@@ -36,20 +36,35 @@ endef
 
 $(eval $(call KernelPackage,swconfig))
 
-define KernelPackage/switch-ip175c
+define KernelPackage/mvswitch
   SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=IC+ IP175C/IP178C switch support
+  TITLE:=Marvell 88E6060 switch support
   DEPENDS:=+kmod-swconfig
-  KCONFIG:=CONFIG_IP175C_PHY
-  FILES:=$(LINUX_DIR)/drivers/net/phy/ip175c.ko
-  AUTOLOAD:=$(call AutoLoad,42,ip175c)
+  KCONFIG:=CONFIG_MVSWITCH_PHY
+  FILES:=$(LINUX_DIR)/drivers/net/phy/mvswitch.ko
+  AUTOLOAD:=$(call AutoLoad,41,mvswitch)
 endef
 
-define KernelPackage/switch-ip175c/description
+define KernelPackage/mvswitch/description
+  Marvell 88E6060 switch support
+endef
+
+$(eval $(call KernelPackage,mvswitch))
+
+define KernelPackage/switch-ip17xx
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=IC+ IP17XX switch support
+  DEPENDS:=+kmod-swconfig
+  KCONFIG:=CONFIG_IP17XX_PHY
+  FILES:=$(LINUX_DIR)/drivers/net/phy/ip17xx.ko
+  AUTOLOAD:=$(call AutoLoad,42,ip17xx)
+endef
+
+define KernelPackage/switch-ip17xx/description
   IC+ IP175C/IP178C switch support
 endef
 
-$(eval $(call KernelPackage,switch-ip175c))
+$(eval $(call KernelPackage,switch-ip17xx))
 
 define KernelPackage/natsemi
   SUBMENU:=$(NETWORK_DEVICES_MENU)
@@ -155,6 +170,20 @@ endef
 
 $(eval $(call KernelPackage,via-velocity))
 
+define KernelPackage/ixp4xx-eth
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=IXP4xxt Ethernet Adapter kernel support
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:=CONFIG_IXP4XX_ETH
+  FILES:=$(LINUX_DIR)/drivers/net/arm/ixp4xx_eth.ko
+  AUTOLOAD:=$(call AutoLoad,50,ixp4xx_eth)
+endef
+
+define KernelPackage/ixp4xx-eth/description
+ Kernel modules for Intel IXP4xx Ethernet chipsets.
+endef
+
+$(eval $(call KernelPackage,ixp4xx-eth))
 
 define KernelPackage/8139too
   SUBMENU:=$(NETWORK_DEVICES_MENU)
@@ -176,6 +205,22 @@ endef
 $(eval $(call KernelPackage,8139too))
 
 
+define KernelPackage/8139cp
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=RealTek RTL-8139C+ PCI Fast Ethernet Adapter kernel support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_8139CP
+  FILES:=$(LINUX_DIR)/drivers/net/8139cp.ko
+  AUTOLOAD:=$(call AutoLoad,50,8139cp)
+endef
+
+define KernelPackage/8139cp/description
+ Kernel module for RealTek RTL-8139C+ PCI Fast Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,8139cp))
+
+
 define KernelPackage/r8169
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
@@ -236,7 +281,7 @@ define KernelPackage/e1000
     CONFIG_E1000_DISABLE_PACKET_SPLIT=n \
     CONFIG_E1000_NAPI=y
   FILES:=$(LINUX_DIR)/drivers/net/e1000/e1000.ko
-  AUTOLOAD:=$(call AutoLoad,50,e1000)
+  AUTOLOAD:=$(call AutoLoad,35,e1000)
 endef
 
 define KernelPackage/e1000/description
@@ -439,3 +484,34 @@ define KernelPackage/tulip/description
 endef
 
 $(eval $(call KernelPackage,tulip))
+
+
+define KernelPackage/solos-pci
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Solos ADSL2+ multiport modem
+  DEPENDS:=@TARGET_x86 +kmod-atm
+  KCONFIG:=CONFIG_ATM_SOLOS
+  FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
+  AUTOLOAD:=$(call AutoLoad,50,solos-pci)
+endef
+
+define KernelPackage/solos-pci/description
+ Kernel module for Traverse Technologies' Solos PCI cards
+ and Geos ADSL2+ x86 motherboard.
+endef
+
+$(eval $(call KernelPackage,solos-pci))
+
+define KernelPackage/dummy
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Dummy network device
+  KCONFIG:=CONFIG_DUMMY
+  FILES:=$(LINUX_DIR)/drivers/net/dummy.ko
+  AUTOLOAD:=$(call AutoLoad,34,dummy)
+endef
+
+define KernelPackage/dummy/description
+  The dummy network device
+endef
+
+$(eval $(call KernelPackage,dummy))