[netfilter] package TPROXY target and module infrastructure
[openwrt/svn-archive/archive.git] / package / kernel / modules / netfilter.mk
index 5817595649e68fa800110175693dfeb4926e6b66..3fbd641318603ae649d8e74bd85743da02f43c76 100644 (file)
@@ -1,10 +1,10 @@
+
 #
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 NF_MENU:=Netfilter Extensions
 NF_KMOD:=1
 
 NF_MENU:=Netfilter Extensions
 NF_KMOD:=1
@@ -21,29 +21,39 @@ endef
 define KernelPackage/ipt-core/description
  Netfilter core kernel modules
  Includes:
 define KernelPackage/ipt-core/description
  Netfilter core kernel modules
  Includes:
+ - comment (2.6)
  - limit
  - LOG
  - mac
  - multiport
  - limit
  - LOG
  - mac
  - multiport
- - TCPMSS
  - REJECT
  - REJECT
+ - TCPMSS
 endef
 
 $(eval $(call KernelPackage,ipt-core))
 
 
 endef
 
 $(eval $(call KernelPackage,ipt-core))
 
 
-define KernelPackage/ipt-conntrack
+define AddDepends/ipt
   SUBMENU:=$(NF_MENU)
   SUBMENU:=$(NF_MENU)
+  DEPENDS+= kmod-ipt-core $(1)
+endef
+
+
+define KernelPackage/ipt-conntrack
   TITLE:=Basic connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK)
   FILES:=$(foreach mod,$(IPT_CONNTRACK-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,41,$(notdir $(IPT_CONNTRACK-m)))
   TITLE:=Basic connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK)
   FILES:=$(foreach mod,$(IPT_CONNTRACK-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,41,$(notdir $(IPT_CONNTRACK-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-conntrack/description
  Netfilter (IPv4) kernel modules for connection tracking
  Includes:
 endef
 
 define KernelPackage/ipt-conntrack/description
  Netfilter (IPv4) kernel modules for connection tracking
  Includes:
+ - conntrack
+ - defrag (2.6)
+ - iptables_raw
+ - NOTRACK
  - state
 endef
 
  - state
 endef
 
@@ -51,12 +61,11 @@ $(eval $(call KernelPackage,ipt-conntrack))
 
 
 define KernelPackage/ipt-conntrack-extra
 
 
 define KernelPackage/ipt-conntrack-extra
-  SUBMENU:=$(NF_MENU)
   TITLE:=Extra connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK_EXTRA)
   FILES:=$(foreach mod,$(IPT_CONNTRACK_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,42,$(notdir $(IPT_CONNTRACK_EXTRA-m)))
   TITLE:=Extra connection tracking modules
   KCONFIG:=$(KCONFIG_IPT_CONNTRACK_EXTRA)
   FILES:=$(foreach mod,$(IPT_CONNTRACK_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,42,$(notdir $(IPT_CONNTRACK_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core +kmod-ipt-conntrack
+  $(call AddDepends/ipt,+kmod-ipt-conntrack)
 endef
 
 define KernelPackage/ipt-conntrack-extra/description
 endef
 
 define KernelPackage/ipt-conntrack-extra/description
@@ -67,82 +76,82 @@ define KernelPackage/ipt-conntrack-extra/description
  - conntrack
  - helper
  - recent
  - conntrack
  - helper
  - recent
- - NOTRACK
 endef
 
 $(eval $(call KernelPackage,ipt-conntrack-extra))
 
 
 define KernelPackage/ipt-filter
 endef
 
 $(eval $(call KernelPackage,ipt-conntrack-extra))
 
 
 define KernelPackage/ipt-filter
-  SUBMENU:=$(NF_MENU)
   TITLE:=Modules for packet content inspection
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_FILTER-m)))
   TITLE:=Modules for packet content inspection
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_FILTER-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt,+LINUX_2_6:kmod-textsearch)
 endef
 
 define KernelPackage/ipt-filter/description
  Netfilter (IPv4) kernel modules for packet content inspection
  Includes:
 endef
 
 define KernelPackage/ipt-filter/description
  Netfilter (IPv4) kernel modules for packet content inspection
  Includes:
- - ipt_layer7
- - ipt_string
+ - layer7
+ - string
 endef
 
 $(eval $(call KernelPackage,ipt-filter))
 
 
 define KernelPackage/ipt-ipopt
 endef
 
 $(eval $(call KernelPackage,ipt-filter))
 
 
 define KernelPackage/ipt-ipopt
-  SUBMENU:=$(NF_MENU)
   TITLE:=Modules for matching/changing IP packet options
   KCONFIG:=$(KCONFIG_IPT_IPOPT)
   FILES:=$(foreach mod,$(IPT_IPOPT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPOPT-m)))
   TITLE:=Modules for matching/changing IP packet options
   KCONFIG:=$(KCONFIG_IPT_IPOPT)
   FILES:=$(foreach mod,$(IPT_IPOPT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPOPT-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-ipopt/description
  Netfilter (IPv4) modules for matching/changing IP packet options
  Includes:
 endef
 
 define KernelPackage/ipt-ipopt/description
  Netfilter (IPv4) modules for matching/changing IP packet options
  Includes:
- - ipt_CLASSIFY
- - ipt_dscp/DSCP
- - ipt_ecn/ECN
- - ipt_length
- - ipt_tos/TOS
- - ipt_tcpmms
- - ipt_ttl/TTL
- - ipt_unclean
+ - CLASSIFY
+ - dscp/DSCP
+ - ecn/ECN
+ - hl/HL (2.6.30 and later)
+ - length
+ - mark/MARK
+ - statistic (2.6)
+ - tcpmss
+ - time
+ - tos/TOS (prior to 2.6.25)
+ - ttl/TTL (prior to 2.6.30)
+ - unclean
 endef
 
 $(eval $(call KernelPackage,ipt-ipopt))
 
 
 define KernelPackage/ipt-ipsec
 endef
 
 $(eval $(call KernelPackage,ipt-ipopt))
 
 
 define KernelPackage/ipt-ipsec
-  SUBMENU:=$(NF_MENU)
   TITLE:=Modules for matching IPSec packets
   KCONFIG:=$(KCONFIG_IPT_IPSEC)
   FILES:=$(foreach mod,$(IPT_IPSEC-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPSEC-m)))
   TITLE:=Modules for matching IPSec packets
   KCONFIG:=$(KCONFIG_IPT_IPSEC)
   FILES:=$(foreach mod,$(IPT_IPSEC-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPSEC-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-ipsec/description
  Netfilter (IPv4) modules for matching IPSec packets
  Includes:
 endef
 
 define KernelPackage/ipt-ipsec/description
  Netfilter (IPv4) modules for matching IPSec packets
  Includes:
- - ipt_ah
- - ipt_esp
+ - ah
+ - esp
+ - policy (2.6)
 endef
 
 $(eval $(call KernelPackage,ipt-ipsec))
 
 
 define KernelPackage/ipt-nat
 endef
 
 $(eval $(call KernelPackage,ipt-ipsec))
 
 
 define KernelPackage/ipt-nat
-  SUBMENU:=$(NF_MENU)
   TITLE:=Basic NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT)
   FILES:=$(foreach mod,$(IPT_NAT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,42,$(notdir $(IPT_NAT-m)))
   TITLE:=Basic NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT)
   FILES:=$(foreach mod,$(IPT_NAT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,42,$(notdir $(IPT_NAT-m)))
-  DEPENDS:= kmod-ipt-core +kmod-ipt-conntrack
+  $(call AddDepends/ipt,+kmod-ipt-conntrack)
 endef
 
 define KernelPackage/ipt-nat/description
 endef
 
 define KernelPackage/ipt-nat/description
@@ -155,18 +164,17 @@ $(eval $(call KernelPackage,ipt-nat))
 
 
 define KernelPackage/ipt-nat-extra
 
 
 define KernelPackage/ipt-nat-extra
-  SUBMENU:=$(NF_MENU)
   TITLE:=Extra NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT_EXTRA)
   FILES:=$(foreach mod,$(IPT_NAT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,43,$(notdir $(IPT_NAT_EXTRA-m)))
   TITLE:=Extra NAT targets
   KCONFIG:=$(KCONFIG_IPT_NAT_EXTRA)
   FILES:=$(foreach mod,$(IPT_NAT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,43,$(notdir $(IPT_NAT_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core +kmod-ipt-nat
+  $(call AddDepends/ipt,+kmod-ipt-nat)
 endef
 
 define KernelPackage/ipt-nat-extra/description
  Netfilter (IPv4) kernel modules for extra NAT targets
  Includes:
 endef
 
 define KernelPackage/ipt-nat-extra/description
  Netfilter (IPv4) kernel modules for extra NAT targets
  Includes:
- - MIRROR
+ - MIRROR (2.4)
  - NETMAP
  - REDIRECT
 endef
  - NETMAP
  - REDIRECT
 endef
@@ -175,69 +183,63 @@ $(eval $(call KernelPackage,ipt-nat-extra))
 
 
 define KernelPackage/ipt-nathelper
 
 
 define KernelPackage/ipt-nathelper
-  SUBMENU:=$(NF_MENU)
   TITLE:=Basic Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER)
   FILES:=$(foreach mod,$(IPT_NATHELPER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_NATHELPER-m)))
   TITLE:=Basic Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER)
   FILES:=$(foreach mod,$(IPT_NATHELPER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_NATHELPER-m)))
-  DEPENDS:= kmod-ipt-core +kmod-ipt-nat
+  $(call AddDepends/ipt,+kmod-ipt-nat)
 endef
 
 define KernelPackage/ipt-nathelper/description
  Default Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
 endef
 
 define KernelPackage/ipt-nathelper/description
  Default Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - conntrack_ftp
- - nat_ftp
- - conntrack_irc
- - nat_irc
- - conntrack_tftp
- - nat_tftp
+ - ftp
+ - irc
+ - tftp
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper))
 
 
 define KernelPackage/ipt-nathelper-extra
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper))
 
 
 define KernelPackage/ipt-nathelper-extra
-  SUBMENU:=$(NF_MENU)
   TITLE:=Extra Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER_EXTRA)
   FILES:=$(foreach mod,$(IPT_NATHELPER_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_NATHELPER_EXTRA-m)))
   TITLE:=Extra Conntrack and NAT helpers
   KCONFIG:=$(KCONFIG_IPT_NATHELPER_EXTRA)
   FILES:=$(foreach mod,$(IPT_NATHELPER_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_NATHELPER_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core +kmod-ipt-nat
+  $(call AddDepends/ipt,+kmod-ipt-nat +LINUX_2_6:kmod-textsearch)
 endef
 
 define KernelPackage/ipt-nathelper-extra/description
  Extra Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
 endef
 
 define KernelPackage/ipt-nathelper-extra/description
  Extra Netfilter (IPv4) Conntrack and NAT helpers
  Includes:
- - ip_conntrack_amanda
- - ip_conntrack_proto_gre
- - ip_nat_proto_gre
- - ip_conntrack_pptp
- - ip_nat_pptp
- - ip_conntrack_sip
- - ip_nat_sip
- - ip_nat_snmp_basic
+ - amanda
+ - h323
+ - mms
+ - pptp (2.6)
+ - proto_gre (2.6)
+ - rtsp
+ - sip (2.6)
+ - snmp_basic
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper-extra))
 
 
 define KernelPackage/ipt-imq
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper-extra))
 
 
 define KernelPackage/ipt-imq
-  SUBMENU:=$(NF_MENU)
   TITLE:=Intermediate Queueing support
   KCONFIG:= \
        CONFIG_IMQ \
        CONFIG_IMQ_BEHAVIOR_BA=y \
        CONFIG_IMQ_NUM_DEVS=2 \
   TITLE:=Intermediate Queueing support
   KCONFIG:= \
        CONFIG_IMQ \
        CONFIG_IMQ_BEHAVIOR_BA=y \
        CONFIG_IMQ_NUM_DEVS=2 \
-       CONFIG_IP_NF_TARGET_IMQ
+       CONFIG_NETFILTER_XT_TARGET_IMQ
   FILES:= \
        $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX) \
        $(foreach mod,$(IPT_IMQ-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   FILES:= \
        $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX) \
        $(foreach mod,$(IPT_IMQ-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
-  AUTOLOAD:=$(call AutoLoad,45,$(notdir \
+  AUTOLOAD:=$(call AutoLoad,46,$(notdir \
        imq \
        $(IPT_IMQ-m) \
   ))
        imq \
        $(IPT_IMQ-m) \
   ))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-imq/description
 endef
 
 define KernelPackage/ipt-imq/description
@@ -248,12 +250,11 @@ $(eval $(call KernelPackage,ipt-imq))
 
 
 define KernelPackage/ipt-queue
 
 
 define KernelPackage/ipt-queue
-  SUBMENU:=$(NF_MENU)
   TITLE:=Module for user-space packet queueing
   KCONFIG:=$(KCONFIG_IPT_QUEUE)
   FILES:=$(foreach mod,$(IPT_QUEUE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_QUEUE-m)))
   TITLE:=Module for user-space packet queueing
   KCONFIG:=$(KCONFIG_IPT_QUEUE)
   FILES:=$(foreach mod,$(IPT_QUEUE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_QUEUE-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-queue/description
 endef
 
 define KernelPackage/ipt-queue/description
@@ -266,87 +267,76 @@ $(eval $(call KernelPackage,ipt-queue))
 
 
 define KernelPackage/ipt-ulog
 
 
 define KernelPackage/ipt-ulog
-  SUBMENU:=$(NF_MENU)
   TITLE:=Module for user-space packet logging
   KCONFIG:=$(KCONFIG_IPT_ULOG)
   FILES:=$(foreach mod,$(IPT_ULOG-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_ULOG-m)))
   TITLE:=Module for user-space packet logging
   KCONFIG:=$(KCONFIG_IPT_ULOG)
   FILES:=$(foreach mod,$(IPT_ULOG-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_ULOG-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-ulog/description
  Netfilter (IPv4) module for user-space packet logging
  Includes:
 endef
 
 define KernelPackage/ipt-ulog/description
  Netfilter (IPv4) module for user-space packet logging
  Includes:
- - ipt_ULOG
+ - ULOG
 endef
 
 $(eval $(call KernelPackage,ipt-ulog))
 
 
 endef
 
 $(eval $(call KernelPackage,ipt-ulog))
 
 
+define KernelPackage/ipt-tproxy
+  TITLE:=Transparent proxying support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_NETFILTER_TPROXY \
+       CONFIG_NETFILTER_XT_MATCH_SOCKET \
+       CONFIG_NETFILTER_XT_TARGET_TPROXY
+  FILES:= \
+       $(LINUX_DIR)/net/netfilter/nf_tproxy_core.$(LINUX_KMOD_SUFFIX) \
+       $(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tproxy_core $(IPT_TPROXY-m)))
+  $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-tproxy/description
+  Kernel modules for Transparent Proxying
+endef
+
+$(eval $(call KernelPackage,ipt-tproxy))
+
+
 define KernelPackage/ipt-iprange
 define KernelPackage/ipt-iprange
-  SUBMENU:=$(NF_MENU)
   TITLE:=Module for matching ip ranges
   TITLE:=Module for matching ip ranges
+  KCONFIG:=$(KCONFIG_IPT_IPRANGE)
   FILES:=$(foreach mod,$(IPT_IPRANGE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPRANGE-m)))
   FILES:=$(foreach mod,$(IPT_IPRANGE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPRANGE-m)))
-  DEPENDS:= kmod-ipt-core
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-iprange/description
  Netfilter (IPv4) module for matching ip ranges
  Includes:
 endef
 
 define KernelPackage/ipt-iprange/description
  Netfilter (IPv4) module for matching ip ranges
  Includes:
- - ipt_IPRANGE
+ - iprange
 endef
 
 $(eval $(call KernelPackage,ipt-iprange))
 
 
 endef
 
 $(eval $(call KernelPackage,ipt-iprange))
 
 
-define KernelPackage/ipt-ipset
-  SUBMENU:=$(NF_MENU)
-  TITLE:=IPSET Modules
-  KCONFIG:=$(KCONFIG_IPT_IPSET)
-  FILES:=$(foreach mod,$(IPT_IPSET-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
-  AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_IPSET-m)))
-  DEPENDS:= kmod-ipt-core
-endef
-
-define KernelPackage/ipt-ipset/description
- Netfilter kernel modules for ipset
- Includes:
- - ip_set
- - ip_set_iphash
- - ip_set_ipmap
- - ip_set_ipporthash
- - ip_set_iptree
- - ip_set_iptreemap
- - ip_set_macipmap
- - ip_set_nethash
- - ip_set_portmap
- - ipt_set
- - ipt_SET
-endef
-
-$(eval $(call KernelPackage,ipt-ipset))
-
-
-# XXX: broken on 2.6.28 to xt_CHAOS module
 define KernelPackage/ipt-extra
 define KernelPackage/ipt-extra
-  SUBMENU:=$(NF_MENU)
   TITLE:=Extra modules
   KCONFIG:=$(KCONFIG_IPT_EXTRA)
   FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_EXTRA-m)))
   TITLE:=Extra modules
   KCONFIG:=$(KCONFIG_IPT_EXTRA)
   FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core @LINUX_2_6_28:BROKEN
+  $(call AddDepends/ipt)
 endef
 
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
  Includes:
 endef
 
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
  Includes:
- - ipt_owner
- - ipt_physdev
- - ipt_pkttype
- - ipt_recent
- - iptable_raw
- - xt_NOTRACK
+ - condition (2.4 only)
+ - owner
+ - physdev (if bridge support was enabled in kernel)
+ - pkttype
+ - quota
 endef
 
 $(eval $(call KernelPackage,ipt-extra))
 endef
 
 $(eval $(call KernelPackage,ipt-extra))
@@ -356,7 +346,7 @@ define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
   DEPENDS:=+kmod-ipv6
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
   DEPENDS:=+kmod-ipv6
-  KCONFIG:=CONFIG_IP6_NF_IPTABLES
+  KCONFIG:=$(KCONFIG_IPT_IPV6)
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))
 endef
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))
 endef
@@ -372,8 +362,10 @@ define KernelPackage/arptables
   SUBMENU:=$(NF_MENU)
   TITLE:=ARP firewalling modules
   FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=$(NF_MENU)
   TITLE:=ARP firewalling modules
   FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)
-  KCONFIG:=CONFIG_IP_NF_ARPTABLES
-  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)))))
+  KCONFIG:=CONFIG_IP_NF_ARPTABLES \
+    CONFIG_IP_NF_ARPFILTER \
+    CONFIG_IP_NF_ARP_MANGLE
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.$(LINUX_KMOD_SUFFIX),%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)))))
 endef
 
 define KernelPackage/arptables/description
 endef
 
 define KernelPackage/arptables/description
@@ -382,23 +374,80 @@ endef
 
 $(eval $(call KernelPackage,arptables))
 
 
 $(eval $(call KernelPackage,arptables))
 
+
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
   DEPENDS:=@LINUX_2_6
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
   DEPENDS:=@LINUX_2_6
-  FILES:=$(LINUX_DIR)/net/bridge/netfilter/*.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
-       CONFIG_BRIDGE_NF_EBTABLES
-  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,ebtables.ko $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebtable_*.$(LINUX_KMOD_SUFFIX)) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebt_*.$(LINUX_KMOD_SUFFIX)))))
+       $(KCONFIG_EBTABLES)
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(EBTABLES-m)))
 endef
 
 define KernelPackage/ebtables/description
 endef
 
 define KernelPackage/ebtables/description
- Kernel modules for Ethernet Bridge firewalling
+  ebtables is a general, extensible frame/packet identification
+  framework. It provides you to do Ethernet
+  filtering/NAT/brouting on the Ethernet bridge.
 endef
 
 $(eval $(call KernelPackage,ebtables))
 
 
 endef
 
 $(eval $(call KernelPackage,ebtables))
 
 
+define AddDepends/ebtables
+  SUBMENU:=$(NF_MENU)
+  DEPENDS+=kmod-ebtables $(1)
+endef
+
+
+define KernelPackage/ebtables-ipv4
+  TITLE:=ebtables: IPv4 support
+  FILES:=$(foreach mod,$(EBTABLES_IP4-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  KCONFIG:=$(KCONFIG_EBTABLES_IP4)
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(EBTABLES_IP4-m)))
+  $(call AddDepends/ebtables)
+endef
+
+define KernelPackage/ebtables-ipv4/description
+ This option adds the IPv4 support to ebtables, which allows basic
+ IPv4 header field filtering, ARP filtering as well as SNAT, DNAT targets.
+endef
+
+$(eval $(call KernelPackage,ebtables-ipv4))
+
+
+define KernelPackage/ebtables-ipv6
+  TITLE:=ebtables: IPv6 support
+  FILES:=$(foreach mod,$(EBTABLES_IP6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  KCONFIG:=$(KCONFIG_EBTABLES_IP6)
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(EBTABLES_IP6-m)))
+  $(call AddDepends/ebtables)
+endef
+
+define KernelPackage/ebtables-ipv6/description
+ This option adds the IPv6 support to ebtables, which allows basic
+ IPv6 header field filtering and target support.
+endef
+
+$(eval $(call KernelPackage,ebtables-ipv6))
+
+
+define KernelPackage/ebtables-watchers
+  TITLE:=ebtables: watchers support
+  FILES:=$(foreach mod,$(EBTABLES_WATCHERS-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  KCONFIG:=$(KCONFIG_EBTABLES_WATCHERS)
+  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(EBTABLES_WATCHERS-m)))
+  $(call AddDepends/ebtables)
+endef
+
+define KernelPackage/ebtables-watchers/description
+ This option adds the log watchers, that you can use in any rule
+ in any ebtables table.
+endef
+
+$(eval $(call KernelPackage,ebtables-watchers))
+
+
 define KernelPackage/nfnetlink
   SUBMENU:=$(NF_MENU)
   TITLE:=Netlink-based userspace interface
 define KernelPackage/nfnetlink
   SUBMENU:=$(NF_MENU)
   TITLE:=Netlink-based userspace interface
@@ -415,13 +464,18 @@ endef
 $(eval $(call KernelPackage,nfnetlink))
 
 
 $(eval $(call KernelPackage,nfnetlink))
 
 
-define KernelPackage/nfnetlink-log
+define AddDepends/nfnetlink
   SUBMENU:=$(NF_MENU)
   SUBMENU:=$(NF_MENU)
+  DEPENDS+=@LINUX_2_6 +kmod-nfnetlink $(1)
+endef
+
+
+define KernelPackage/nfnetlink-log
   TITLE:=Netfilter LOG over NFNETLINK interface
   TITLE:=Netfilter LOG over NFNETLINK interface
-  DEPENDS:=@LINUX_2_6 +kmod-nfnetlink
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_log.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_LOG
   AUTOLOAD:=$(call AutoLoad,48,nfnetlink_log)
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_log.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_LOG
   AUTOLOAD:=$(call AutoLoad,48,nfnetlink_log)
+  $(call AddDepends/nfnetlink)
 endef
 
 define KernelPackage/nfnetlink-log/description
 endef
 
 define KernelPackage/nfnetlink-log/description
@@ -432,12 +486,11 @@ $(eval $(call KernelPackage,nfnetlink-log))
 
 
 define KernelPackage/nfnetlink-queue
 
 
 define KernelPackage/nfnetlink-queue
-  SUBMENU:=$(NF_MENU)
   TITLE:=Netfilter QUEUE over NFNETLINK interface
   TITLE:=Netfilter QUEUE over NFNETLINK interface
-  DEPENDS:=@LINUX_2_6 +kmod-nfnetlink
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_queue.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_QUEUE
   AUTOLOAD:=$(call AutoLoad,48,nfnetlink_queue)
   FILES:=$(LINUX_DIR)/net/netfilter/nfnetlink_queue.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NETFILTER_NETLINK_QUEUE
   AUTOLOAD:=$(call AutoLoad,48,nfnetlink_queue)
+  $(call AddDepends/nfnetlink)
 endef
 
 define KernelPackage/nfnetlink-queue/description
 endef
 
 define KernelPackage/nfnetlink-queue/description
@@ -448,12 +501,11 @@ $(eval $(call KernelPackage,nfnetlink-queue))
 
 
 define KernelPackage/nf-conntrack-netlink
 
 
 define KernelPackage/nf-conntrack-netlink
-  SUBMENU:=$(NF_MENU)
   TITLE:=Connection tracking netlink interface
   TITLE:=Connection tracking netlink interface
-  DEPENDS:=@LINUX_2_6 +kmod-nfnetlink +kmod-ipt-conntrack
   FILES:=$(LINUX_DIR)/net/netfilter/nf_conntrack_netlink.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NF_CT_NETLINK
   AUTOLOAD:=$(call AutoLoad,49,nf_conntrack_netlink)
   FILES:=$(LINUX_DIR)/net/netfilter/nf_conntrack_netlink.$(LINUX_KMOD_SUFFIX)
   KCONFIG:=CONFIG_NF_CT_NETLINK
   AUTOLOAD:=$(call AutoLoad,49,nf_conntrack_netlink)
+  $(call AddDepends/nfnetlink,+kmod-ipt-conntrack)
 endef
 
 define KernelPackage/nf-conntrack-netlink/description
 endef
 
 define KernelPackage/nf-conntrack-netlink/description