cosmetic change: rename IPT_NAT_DEFAULT & IPT_NAT_EXTRA to IPT_NATHELPER & IPT_NATHEL...
[openwrt/svn-archive/archive.git] / package / kernel / modules / netfilter.mk
index d25296bec04a43fa51b7451563ca6e0cb8353cf0..af68d079c7587d0bed5b723657b569ab2930d45d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,6 +7,7 @@
 # $Id$
 
 NF_MENU:=Netfilter Extensions
+NF_KMOD:=1
 include $(INCLUDE_DIR)/netfilter.mk
 
 define KernelPackage/ipt-conntrack
@@ -19,9 +20,9 @@ endef
 
 define KernelPackage/ipt-conntrack/description
  Netfilter (IPv4) kernel modules for connection tracking
- Includes: 
- - ipt_conntrack 
- - ipt_helper 
+ Includes:
+ - ipt_conntrack
+ - ipt_helper
  - ipt_connmark/CONNMARK
 endef
 
@@ -37,9 +38,9 @@ define KernelPackage/ipt-filter
 endef
 
 define KernelPackage/ipt-filter/description
- Netfilter (IPv4) kernel modules for packet content inspection 
- Includes: 
- - ipt_ipp2p 
+ Netfilter (IPv4) kernel modules for packet content inspection
+ Includes:
+ - ipt_ipp2p
  - ipt_layer7
 endef
 
@@ -55,16 +56,16 @@ define KernelPackage/ipt-ipopt
 endef
 
 define KernelPackage/ipt-ipopt/description
- Netfilter (IPv4) modules for matching/changing IP packet options 
- Includes: 
- - ipt_CLASSIFY 
- - ipt_dscp/DSCP 
- - ipt_ecn/ECN 
- - ipt_length 
- - ipt_mac 
- - ipt_tos/TOS 
- - ipt_tcpmms 
- - ipt_ttl/TTL 
+ Netfilter (IPv4) modules for matching/changing IP packet options
+ Includes:
+ - ipt_CLASSIFY
+ - ipt_dscp/DSCP
+ - ipt_ecn/ECN
+ - ipt_length
+ - ipt_mac
+ - ipt_tos/TOS
+ - ipt_tcpmms
+ - ipt_ttl/TTL
  - ipt_unclean
 endef
 
@@ -80,9 +81,9 @@ define KernelPackage/ipt-ipsec
 endef
 
 define KernelPackage/ipt-ipsec/description
- Netfilter (IPv4) modules for matching IPSec packets 
- Includes: 
- - ipt_ah 
+ Netfilter (IPv4) modules for matching IPSec packets
+ Includes:
+ - ipt_ah
  - ipt_esp
 endef
 
@@ -98,9 +99,9 @@ define KernelPackage/ipt-nat
 endef
 
 define KernelPackage/ipt-nat/description
- Netfilter (IPv4) modules for extra NAT targets 
- Includes: 
- - ipt_REDIRECT 
+ Netfilter (IPv4) modules for extra NAT targets
+ Includes:
+ - ipt_REDIRECT
  - ipt_NETMAP
 endef
 
@@ -110,18 +111,18 @@ $(eval $(call KernelPackage,ipt-nat))
 define KernelPackage/ipt-nathelper
   SUBMENU:=$(NF_MENU)
   TITLE:=Default Conntrack and NAT helpers
-  KCONFIG:=$(KCONFIG_IPT_NAT_DEFAULT)
-  FILES:=$(foreach mod,$(IPT_NAT_DEFAULT-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
-  AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_NAT_DEFAULT-m)))
+  KCONFIG:=$(KCONFIG_IPT_NATHELPER)
+  FILES:=$(foreach mod,$(IPT_NAT_NATHELPER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_NAT_NATHELPER-m)))
 endef
 
 define KernelPackage/ipt-nathelper/description
- Default Netfilter (IPv4) Conntrack and NAT helpers 
- Includes: 
- - ip_conntrack_ftp 
- - ip_nat_ftp 
- - ip_conntrack_irc 
- - ip_nat_irc 
+ Default Netfilter (IPv4) Conntrack and NAT helpers
+ Includes:
+ - ip_conntrack_ftp
+ - ip_nat_ftp
+ - ip_conntrack_irc
+ - ip_nat_irc
  - ip_conntrack_tftp
 endef
 
@@ -131,21 +132,21 @@ $(eval $(call KernelPackage,ipt-nathelper))
 define KernelPackage/ipt-nathelper-extra
   SUBMENU:=$(NF_MENU)
   TITLE:=Extra Conntrack and NAT helpers
-  KCONFIG:=$(KCONFIG_IPT_NAT_EXTRA)
-  FILES:=$(foreach mod,$(IPT_NAT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
-  AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_NAT_EXTRA-m)))
+  KCONFIG:=$(KCONFIG_IPT_NATHELPER_EXTRA)
+  FILES:=$(foreach mod,$(IPT_NATHELPER_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
+  AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_NATHELPER_EXTRA-m)))
 endef
 
 define KernelPackage/ipt-nathelper-extra/description
- Extra Netfilter (IPv4) Conntrack and NAT helpers 
- Includes: 
- - ip_conntrack_amanda 
- - ip_conntrack_proto_gre 
- - ip_nat_proto_gre 
- - ip_conntrack_pptp 
- - ip_nat_pptp 
- - ip_conntrack_sip 
- - ip_nat_sip 
+ Extra Netfilter (IPv4) Conntrack and NAT helpers
+ Includes:
+ - ip_conntrack_amanda
+ - ip_conntrack_proto_gre
+ - ip_nat_proto_gre
+ - ip_conntrack_pptp
+ - ip_nat_pptp
+ - ip_conntrack_sip
+ - ip_nat_sip
  - ip_nat_snmp_basic
 endef
 
@@ -156,6 +157,7 @@ define KernelPackage/ipt-imq
   SUBMENU:=$(NF_MENU)
   TITLE:=Intermediate Queueing support
   KCONFIG:=CONFIG_IP_NF_TARGET_IMQ
+  DEPENDS:=@!LINUX_2_6_25
   FILES:=$(LINUX_DIR)/net/ipv4/netfilter/*IMQ*.$(LINUX_KMOD_SUFFIX) $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/*IMQ*.$(LINUX_KMOD_SUFFIX) $(LINUX_DIR)/drivers/net/imq.$(LINUX_KMOD_SUFFIX)))))
 endef
@@ -176,8 +178,8 @@ define KernelPackage/ipt-queue
 endef
 
 define KernelPackage/ipt-queue/description
- Netfilter (IPv4) module for user-space packet queueing 
- Includes: 
+ Netfilter (IPv4) module for user-space packet queueing
+ Includes:
  - ipt_QUEUE
 endef
 
@@ -193,8 +195,8 @@ define KernelPackage/ipt-ulog
 endef
 
 define KernelPackage/ipt-ulog/description
- Netfilter (IPv4) module for user-space packet logging 
- Includes: 
+ Netfilter (IPv4) module for user-space packet logging
+ Includes:
  - ipt_ULOG
 endef
 
@@ -204,13 +206,13 @@ $(eval $(call KernelPackage,ipt-ulog))
 define KernelPackage/ipt-iprange
   SUBMENU:=$(NF_MENU)
   TITLE:=Module for matching ip ranges
-  FILES:=$(LINUX_DIR)/net/ipv4/netfilter/ipt_iprange.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(foreach mod,$(IPT_IPRANGE-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPRANGE-m)))
 endef
 
 define KernelPackage/ipt-iprange/description
- Netfilter (IPv4) module for matching ip ranges 
- Includes: 
+ Netfilter (IPv4) module for matching ip ranges
+ Includes:
  - ipt_IPRANGE
 endef
 
@@ -227,6 +229,18 @@ endef
 
 define KernelPackage/ipt-ipset/description
  Netfilter kernel modules for ipset
+ Includes:
+ - ip_set
+ - ip_set_iphash
+ - ip_set_ipmap
+ - ip_set_ipporthash
+ - ip_set_iptree
+ - ip_set_iptreemap
+ - ip_set_macipmap
+ - ip_set_nethash
+ - ip_set_portmap
+ - ipt_set
+ - ipt_SET
 endef
 
 $(eval $(call KernelPackage,ipt-ipset))
@@ -242,14 +256,17 @@ endef
 
 define KernelPackage/ipt-extra/description
  Other Netfilter (IPv4) kernel modules
- Includes: 
- - ipt_limit 
- - ipt_owner 
- - ipt_physdev 
- - ipt_pkttype 
- - ipt_recent 
- - iptable_raw 
- - xt_NOTRACK 
+ Includes:
+ - ipt_limit
+ - ipt_owner
+ - ipt_physdev
+ - ipt_pkttype
+ - ipt_recent
+ - iptable_raw
+ - xt_NOTRACK
+ - xt_TARPIT
+ - xt_DELUDE
+ - xt_CHAOS
 endef
 
 $(eval $(call KernelPackage,ipt-extra))
@@ -258,6 +275,7 @@ $(eval $(call KernelPackage,ipt-extra))
 define KernelPackage/ip6tables
   SUBMENU:=$(NF_MENU)
   TITLE:=IPv6 modules
+  DEPENDS:=+kmod-ipv6
   KCONFIG:=CONFIG_IP6_NF_IPTABLES
   FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(IPT_IPV6-m)))