[package] kernel: mark modules that won't build on 2.6.28 as broken
[openwrt/svn-archive/archive.git] / package / kernel / modules / netfilter.mk
index 0d86adffc3377f2bac2fa133339584e0ddf181d1..c17c8a8def3116c673ef0e7f61af1d8565607917 100644 (file)
@@ -328,13 +328,14 @@ endef
 $(eval $(call KernelPackage,ipt-ipset))
 
 
+# XXX: broken on 2.6.28 to xt_CHAOS module
 define KernelPackage/ipt-extra
   SUBMENU:=$(NF_MENU)
   TITLE:=Extra modules
   KCONFIG:=$(KCONFIG_IPT_EXTRA)
   FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core
+  DEPENDS:= kmod-ipt-core @LINUX_2_6_28:BROKEN
 endef
 
 define KernelPackage/ipt-extra/description