[brcm47xx] move usb driver to target specific modules.mk
[openwrt/svn-archive/archive.git] / package / kernel / modules / netfilter.mk
index 61226ee7f09abee1858ab3654395d810cd8c3b4d..ff34664c212d866007db787566fbdfeee1eb8554 100644 (file)
@@ -89,7 +89,7 @@ define KernelPackage/ipt-filter
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_FILTER-m)))
-  $(call AddDepends/ipt,+kmod-textsearch)
+  $(call AddDepends/ipt,+kmod-lib-textsearch)
 endef
 
 define KernelPackage/ipt-filter/description
@@ -122,6 +122,7 @@ define KernelPackage/ipt-ipopt/description
  - statistic
  - tcpmss
  - time
+ - ttl/TTL
  - unclean
 endef
 
@@ -206,7 +207,7 @@ define KernelPackage/ipt-nathelper-extra
   KCONFIG:=$(KCONFIG_IPT_NATHELPER_EXTRA)
   FILES:=$(foreach mod,$(IPT_NATHELPER_EXTRA-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_NATHELPER_EXTRA-m)))
-  $(call AddDepends/ipt,+kmod-ipt-nat +kmod-textsearch)
+  $(call AddDepends/ipt,+kmod-ipt-nat +kmod-lib-textsearch)
 endef
 
 define KernelPackage/ipt-nathelper-extra/description
@@ -217,9 +218,9 @@ define KernelPackage/ipt-nathelper-extra/description
  - mms
  - pptp
  - proto_gre
- - rtsp
  - sip
  - snmp_basic
+ - broadcast
 endef
 
 $(eval $(call KernelPackage,ipt-nathelper-extra))
@@ -311,6 +312,41 @@ endef
 
 $(eval $(call KernelPackage,ipt-tproxy))
 
+define KernelPackage/ipt-tee
+  TITLE:=TEE support
+  KCONFIG:= \
+       CONFIG_NETFILTER_XT_TARGET_TEE
+  FILES:= \
+       $(LINUX_DIR)/net/netfilter/xt_TEE.ko \
+       $(foreach mod,$(IPT_TEE-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tee $(IPT_TEE-m)))
+  $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-tee/description
+  Kernel modules for TEE
+endef
+
+$(eval $(call KernelPackage,ipt-tee))
+
+
+define KernelPackage/ipt-u32
+  TITLE:=U32 support
+  KCONFIG:= \
+       CONFIG_NETFILTER_XT_MATCH_U32
+  FILES:= \
+       $(LINUX_DIR)/net/netfilter/xt_u32.ko \
+       $(foreach mod,$(IPT_U32-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tee $(IPT_U32-m)))
+  $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-u32/description
+  Kernel modules for U32
+endef
+
+$(eval $(call KernelPackage,ipt-u32))
+
 
 define KernelPackage/ipt-iprange
   TITLE:=Module for matching ip ranges