add kernel packages for the ixp4xx-beeper and appletalk -- closes #6618
[openwrt/svn-archive/archive.git] / package / kernel / modules / netsupport.mk
index 21abc4c863b92308c0ad3296f409081eb789dbc9..9e9cdcbb637a3ecd05c7067df70093b7f361e533 100644 (file)
@@ -43,6 +43,29 @@ endef
 $(eval $(call KernelPackage,atmtcp))
 
 
+define KernelPackage/appletalk
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Appletalk protocol support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_ATALK \
+       CONFIG_DEV_APPLETALK \
+       CONFIG_IPDDP \
+       CONFIG_IPDDP_ENCAP=y \
+       CONFIG_IPDDP_DECAP=y
+  FILES:= \
+       $(LINUX_DIR)/net/appletalk/appletalk.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/net/appletalk/ipddp.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,appletalk ipddp)
+endef
+
+define KernelPackage/appletalk/description
+ Kernel module for AppleTalk protocol.
+endef
+
+$(eval $(call KernelPackage,appletalk))
+
+
 define KernelPackage/bonding
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Ethernet bonding driver