move the cbc crypto module out of the crypto core and into a separate package - it...
[openwrt/svn-archive/archive.git] / package / kernel / modules / netsupport.mk
index 08068d1e6a9c19be33478156e4a27caef3317cc2..e0e423893fa4c1d49c39ff751a6d3a6df72da6a3 100644 (file)
@@ -177,7 +177,7 @@ IPSEC-m:= \
 define KernelPackage/ipsec
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPsec related modules (IPv4 and IPv6)
-  DEPENDS:=+kmod-crypto-core +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1
+  DEPENDS:=+kmod-crypto-core +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
   KCONFIG:= \
        CONFIG_NET_KEY \
        CONFIG_XFRM_USER \
@@ -473,11 +473,12 @@ define KernelPackage/pppol2tp
   DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37:kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
   ifneq ($(CONFIG_LINUX_2_6_35)$(CONFIG_LINUX_2_6_36)$(CONFIG_LINUX_2_6_37),)
-    FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.mod.o
+    FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
+    AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
   else
     FILES:=$(LINUX_DIR)/drivers/net/pppol2tp.ko
+    AUTOLOAD:=$(call AutoLoad,40,pppol2tp)
   endif
-  AUTOLOAD:=$(call AutoLoad,40,pppol2tp)
 endef
 
 define KernelPackage/pppol2tp/description
@@ -630,10 +631,13 @@ $(eval $(call KernelPackage,pktgen))
 define KernelPackage/l2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37
-  TITLE:=L2TPv3 Support
-  KCONFIG:=CONFIG_L2TP CONFIG_L2TP_DEBUGFS=n
-  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core)
+  TITLE:=Layer Two Tunneling Protocol (L2TP)
+  KCONFIG:=CONFIG_L2TP \
+       CONFIG_L2TP_V3=y \
+       CONFIG_L2TP_DEBUGFS=n
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink)
 endef
 
 define KernelPackage/l2tp/description
@@ -642,36 +646,33 @@ endef
 
 $(eval $(call KernelPackage,l2tp))
 
+
 define KernelPackage/l2tp-eth
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=L2TP ethernet pseudowire support for L2TPv3
   DEPENDS:=+kmod-l2tp
-  KCONFIG:= CONFIG_L2TP_V3=y \
-  CONFIG_L2TP_ETH
-  FILES:= \
-         $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX) \
-         $(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX) 
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink l2tp_eth)
+  KCONFIG:=CONFIG_L2TP_ETH
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX) 
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_eth)
 endef
 
 define KernelPackage/l2tp-eth/description
- Kernel modules for L2TP V3 pseudowire support
+ Kernel modules for L2TP ethernet pseudowire support for L2TPv3
 endef
 
 $(eval $(call KernelPackage,l2tp-eth))
 
 define KernelPackage/l2tp-ip
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=Support for L2TP-over-IP socket family
+  TITLE:=L2TP IP encapsulation for L2TPv3
   DEPENDS:=+kmod-l2tp
-  KCONFIG:= CONFIG_L2TP_V3=y \
-  CONFIG_L2TP_IP
+  KCONFIG:=CONFIG_L2TP_IP
   FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_ip)
+  AUTOLOAD:=$(call AutoLoad,33,l2tp_ip)
 endef
 
 define KernelPackage/l2tp-ip/description
- Kernel modules for L2TP-over-IP socket family
+ Kernel modules for L2TP IP encapsulation for L2TPv3
 endef
 
 $(eval $(call KernelPackage,l2tp-ip))