fix trailing backslash error introduced in r13115 - fixes kernel config issues
[openwrt/svn-archive/archive.git] / package / kernel / modules / network.mk
index c546d638ed0d28f9968a60594ffbe25e390a42c6..238478ff8890e96bcb742aa1c30008b172d671f3 100644 (file)
@@ -319,30 +319,18 @@ $(eval $(call KernelPackage,tun))
 define KernelPackage/ppp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=PPP modules
+  DEPENDS:=+LINUX_2_6:kmod-crc-ccitt
   KCONFIG:= \
        CONFIG_PPP \
        CONFIG_PPP_ASYNC \
-       CONFIG_SLHC \
-       CONFIG_CRC_CCITT
+       CONFIG_SLHC
   FILES:= \
        $(LINUX_DIR)/drivers/net/ppp_async.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/drivers/net/ppp_generic.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/drivers/net/slhc.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/ppp/2.4
   AUTOLOAD:=$(call AutoLoad,30,slhc ppp_generic ppp_async)
 endef
 
-define KernelPackage/ppp/2.6
-#  KCONFIG+= \
-#      CONFIG_SLHC \
-#      CONFIG_CRC_CCITT
-  FILES+= \
-       $(LINUX_DIR)/lib/crc-ccitt.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,crc-ccitt slhc ppp_generic ppp_async)
-endef
-
 define KernelPackage/ppp/description
  Kernel modules for PPP support
 endef