package/kernel: renable kmod-input on 2.4 (closes: #7063)
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index 403af57a739dda69a914c2c792f661c25c632111..261a65e363b89c166f3e339aaabe286c58b23ee2 100644 (file)
@@ -270,10 +270,7 @@ $(eval $(call KernelPackage,hid))
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
-  DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_INPUT
-  FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,19,input-core)
   $(call SetDepends/input)
 endef
 
@@ -281,6 +278,16 @@ define KernelPackage/input-core/description
  Kernel modules for support of input device
 endef
 
+define KernelPackage/input-core/2.4
+  FILES:=$(LINUX_DIR)/drivers/input/input.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,19,input)
+endef
+
+define KernelPackage/input-core/2.6
+  FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,19,input-core)
+endef
+
 $(eval $(call KernelPackage,input-core))