move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index 67e051aa28e75f7f83e83c83fbb4cc744a02caff..475755b6d9d81549e09070484ef0fbbcc6947ad5 100644 (file)
@@ -89,7 +89,6 @@ $(eval $(call KernelPackage,lp))
 define KernelPackage/soundcore
   SUBMENU:=$(EMENU)
   TITLE:=Sound support
-  DESCRIPTION:=Kernel modules for sound support
   KCONFIG:=CONFIG_SOUND
 endef
 
@@ -137,37 +136,46 @@ define KernelPackage/soundcore/uml-2.6
   AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
 endef
 
+define KernelPackage/soundcore/description
+ Kernel modules for sound support
+endef
+
 $(eval $(call KernelPackage,soundcore))
 
 
 define KernelPackage/loop
   SUBMENU:=$(EMENU)
   TITLE:=Loopback device support
-  DESCRIPTION:=Kernel module for loopback device support
   KCONFIG:=CONFIG_BLK_DEV_LOOP
   FILES:=$(LINUX_DIR)/drivers/block/loop.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,loop)
 endef
 
+define KernelPackage/loop/description
+ Kernel module for loopback device support
+endef
+
 $(eval $(call KernelPackage,loop))
 
 
 define KernelPackage/nbd
   SUBMENU:=$(EMENU)
   TITLE:=Network block device support
-  DESCRIPTION:=Kernel module for network block device support
   KCONFIG:=CONFIG_BLK_DEV_NBD
   FILES:=$(LINUX_DIR)/drivers/block/nbd.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,nbd)
 endef
 
+define KernelPackage/nbd/description
+ Kernel module for network block device support
+endef
+
 $(eval $(call KernelPackage,nbd))
 
 
 define KernelPackage/capi
   SUBMENU:=$(EMENU)
   TITLE:=CAPI Support
-  DESCRIPTION:=Kernel module for basic CAPI support
   DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_ISDN \
@@ -179,13 +187,16 @@ define KernelPackage/capi
   AUTOLOAD:=$(call AutoLoad,30,kernelcapi capi)
 endef
 
+define KernelPackage/capi/description
+ Kernel module for basic CAPI support
+endef
+
 $(eval $(call KernelPackage,capi))
 
 
 define KernelPackage/pcmcia-core
   SUBMENU:=$(EMENU)
   TITLE:=PCMCIA/CardBus support
-  DESCRIPTION:=Kernel support for PCMCIA/CardBus controllers
   DEPENDS:=@PCMCIA_SUPPORT
 endef
 
@@ -224,6 +235,9 @@ define KernelPackage/pcmcia-core/au1000-2.6
   AUTOLOAD:=$(call AutoLoad,40,pcmcia_core pcmcia rsrc_nonstatic au1x00_ss)
 endef
 
+define KernelPackage/pcmcia-core/description
+ Kernel support for PCMCIA/CardBus controllers
+endef
 
 $(eval $(call KernelPackage,pcmcia-core))
 
@@ -231,7 +245,6 @@ $(eval $(call KernelPackage,pcmcia-core))
 define KernelPackage/pcmcia-serial
   SUBMENU:=$(EMENU)
   TITLE:=Serial devices support
-  DESCRIPTION:=Kernel support for PCMCIA/CardBus serial devices
   DEPENDS:=kmod-pcmcia-core
   AUTOLOAD:=$(call AutoLoad,45,serial_cs)
 endef
@@ -246,6 +259,10 @@ define KernelPackage/pcmcia-serial/2.6
   FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.$(LINUX_KMOD_SUFFIX)
 endef
 
+define KernelPackage/pcmcia-serial/description
+ Kernel support for PCMCIA/CardBus serial devices
+endef
+
 $(eval $(call KernelPackage,pcmcia-serial))
 
 
@@ -253,7 +270,6 @@ define KernelPackage/bluetooth
   SUBMENU:=$(EMENU)
   TITLE:=Bluetooth support
   DEPENDS:=@USB_SUPPORT
-  DESCRIPTION:=Kernel support for Bluetooth devices
 endef
 
 define KernelPackage/bluetooth/2.4
@@ -296,6 +312,10 @@ define KernelPackage/bluetooth/2.6
   AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hci_uart hci_usb)
 endef
 
+define KernelPackage/bluetooth/description
+ Kernel support for Bluetooth devices
+endef
+
 $(eval $(call KernelPackage,bluetooth))
 
 
@@ -303,7 +323,6 @@ define KernelPackage/mmc
   SUBMENU:=$(EMENU)
   TITLE:=MMC/SD Card Support
   DEPENDS:=@LINUX_2_6_AT91
-  DESCRIPTION:=Kernel support for MMC/SD cards
   KCONFIG:= \
        CONFIG_MMC \
        CONFIG_MMC_BLOCK \
@@ -315,13 +334,16 @@ define KernelPackage/mmc
   AUTOLOAD:=$(call AutoLoad,90,mmc_core mmc_block at91_mci)
 endef
 
+define KernelPackage/mmc/description
+ Kernel support for MMC/SD cards
+endef
+
 $(eval $(call KernelPackage,mmc))
 
 
 define KernelPackage/softdog
   SUBMENU:=$(EMENU)
   TITLE:=Software watchdog driver
-  DESCRIPTION:=Software watchdog driver
   KCONFIG:=CONFIG_SOFT_WATCHDOG
   AUTOLOAD:=$(call AutoLoad,50,softdog)
 endef
@@ -334,13 +356,16 @@ define KernelPackage/softdog/2.6
   FILES:=$(LINUX_DIR)/drivers/char/watchdog/softdog.ko
 endef
 
+define KernelPackage/softdog/description
+ Software watchdog driver
+endef
+
 $(eval $(call KernelPackage,softdog))
 
 
 define KernelPackage/videodev
   SUBMENU:=$(EMENU)
   TITLE=Video4Linux support
-  DESCRIPTION:=Kernel modules for Video4Linux support
   KCONFIG:=CONFIG_VIDEO_DEV
 endef
 
@@ -363,65 +388,80 @@ define KernelPackage/videodev/2.6
   )
 endef
 
+define KernelPackage/videodev/description
+ Kernel modules for Video4Linux support
+endef
+
 $(eval $(call KernelPackage,videodev))
 
 
 define KernelPackage/leds-net48xx
   SUBMENU:=$(EMENU)
   TITLE:=Soekris Net48xx LED support
-  DESCRIPTION:=Kernel module for Soekris Net48xx LEDs
   DEPENDS:=@LINUX_2_6_X86
   KCONFIG:=CONFIG_LEDS_NET48XX
   FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
 endef
 
+define KernelPackage/leds-net48xx/description
+ Kernel module for Soekris Net48xx LEDs
+endef
+
 $(eval $(call KernelPackage,leds-net48xx))
 
 
 define KernelPackage/nsc-gpio
   SUBMENU:=$(EMENU)
   TITLE:=Natsemi GPIO support
-  DESCRIPTION:=Kernel module for Natsemi GPIO
   DEPENDS:=@LINUX_2_6_X86
   KCONFIG:=CONFIG_NSC_GPIO
   FILES:=$(LINUX_DIR)/drivers/char/nsc_gpio.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,40,nsc_gpio)
 endef
 
+define KernelPackage/nsc-gpio/description
+ Kernel module for Natsemi GPIO
+endef
+
 $(eval $(call KernelPackage,nsc-gpio))
 
 
 define KernelPackage/scx200-gpio
   SUBMENU:=$(EMENU)
   TITLE:=Natsemi SCX200 GPIO support
-  DESCRIPTION:=Kernel module for SCX200 GPIO
   DEPENDS:=kmod-nsc-gpio @LINUX_2_6_X86
   KCONFIG:=CONFIG_SCx200_GPIO
   FILES:=$(LINUX_DIR)/drivers/char/scx200_gpio.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,scx200_gpio)
 endef
 
+define KernelPackage/scx200-gpio/description
+ Kernel module for SCX200 GPIO
+endef
+
 $(eval $(call KernelPackage,scx200-gpio))
 
 
 define KernelPackage/scx200-wdt
   SUBMENU:=$(EMENU)
   TITLE:=Natsemi SCX200 Watchdog support
-  DESCRIPTION:=Kernel module for SCX200 Watchdog
   DEPENDS:=@LINUX_2_6_X86
   KCONFIG:=CONFIG_SC1200_WDT
   FILES:=$(LINUX_DIR)/drivers/char/watchdog/scx200_wdt.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,scx200_wdt)
 endef
 
+define KernelPackage/scx200-wdt/description
+ Kernel module for SCX200 Watchdog
+endef
+
 $(eval $(call KernelPackage,scx200-wdt))
 
 
 define KernelPackage/hwmon
   SUBMENU:=$(EMENU)
   TITLE:=Hardware monitoring support
-  DESCRIPTION:=Kernel modules for hardware monitoring
   DEPENDS:=@LINUX_2_6
   KCONFIG:= \
        CONFIG_HWMON \
@@ -433,43 +473,56 @@ define KernelPackage/hwmon
   AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
 endef
 
+define KernelPackage/hwmon/description
+ Kernel modules for hardware monitoring
+endef
+
 $(eval $(call KernelPackage,hwmon))
 
 
 define KernelPackage/hwmon-pc87360
   SUBMENU:=$(EMENU)
   TITLE:=PC87360 monitoring support
-  DESCRIPTION:=Kernel modules for PC87360 chips
   DEPENDS:=kmod-hwmon
   KCONFIG:=CONFIG_SENSORS_PC87360
   FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,pc87360)
 endef
 
+define KernelPackage/hwmon-pc87360/description
+ Kernel modules for PC87360 chips
+endef
+
 $(eval $(call KernelPackage,hwmon-pc87360))
 
 
 define KernelPackage/input-core
   SUBMENU:=$(EMENU)
   TITLE:=Input device core
-  DESCRIPTION:=Kernel modules for support of input device
   DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_INPUT
   FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,input-core)
 endef
 
+define KernelPackage/input-core/description
+ Kernel modules for support of input device
+endef
+
 $(eval $(call KernelPackage,input-core))
 
 
 define KernelPackage/input-evdev
   SUBMENU:=$(EMENU)
   TITLE:=Input even device
-  DESCRIPTION:=Kernel modules for support of input device events
   DEPENDS:=+kmod-input-core
   KCONFIG:=CONFIG_INPUT_EVDEV
   FILES:=$(LINUX_DIR)/drivers/input/evdev.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,evdev)
 endef
 
+define KernelPackage/input-evdev/description
+ Kernel modules for support of input device events
+endef
+
 $(eval $(call KernelPackage,input-evdev))