add a macro to compare kernel patch versions and use it for crypto and watchdog chang...
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index bf674644d4052324793629d39641e53ed26959dc..482c06c4a8195255a5931fc524b9d5f485106373 100644 (file)
@@ -270,7 +270,7 @@ $(eval $(call KernelPackage,mmc-at91))
 ifeq ($(KERNEL),2.4)
   WATCHDOG_DIR=char
 endif
-ifeq ($(KERNEL_PATCHVER),2.6.24)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.24)),1)
   WATCHDOG_DIR=watchdog
 endif
 WATCHDOG_DIR?=char/watchdog