disable another module on UML
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index 79af470e4cd924b5fec3c0a57b757ae932376b91..6d94b77318b41681119b8c3ca9952a367de70ffa 100644 (file)
@@ -92,121 +92,6 @@ endef
 $(eval $(call KernelPackage,lp))
 
 
-define KernelPackage/soundcore
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Sound support
-  KCONFIG:= \
-       CONFIG_SOUND \
-       CONFIG_SND \
-       CONFIG_SND_HWDEP \
-       CONFIG_SND_RAWMIDI \
-       CONFIG_SND_TIMER \
-       CONFIG_SND_PCM \
-       CONFIG_HOSTAUDIO
-endef
-
-define KernelPackage/soundcore/2.4
-  FILES:=$(LINUX_DIR)/drivers/sound/soundcore.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,soundcore)
-endef
-
-define KernelPackage/soundcore/2.6
-#  KCONFIG+= \
-#      CONFIG_SND \
-#      CONFIG_SND_HWDEP \
-#      CONFIG_SND_RAWMIDI \
-#      CONFIG_SND_TIMER \
-#      CONFIG_SND_PCM
-  FILES:= \
-       $(LINUX_DIR)/sound/soundcore.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd-page-alloc.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd-hwdep.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd-rawmidi.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd-timer.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/sound/core/snd-pcm.$(LINUX_KMOD_SUFFIX) \
-       $(if $(CONFIG_SND_MIXER_OSS),$(LINUX_DIR)/sound/core/oss/snd-mixer-oss.$(LINUX_KMOD_SUFFIX)) \
-       $(if $(CONFIG_SND_PCM_OSS),$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.$(LINUX_KMOD_SUFFIX))
-  AUTOLOAD:=$(call AutoLoad,30, \
-       soundcore \
-       snd \
-       snd-page-alloc \
-       snd-hwdep \
-       snd-rawmidi \
-       snd-timer \
-       snd-pcm \
-       $(if $(CONFIG_SND_MIXER_OSS),snd-mixer-oss) \
-       $(if $(CONFIG_SND_PCM_OSS),snd-pcm-oss) \
-  )
-endef
-
-define KernelPackage/soundcore/uml-2.6
-#  KCONFIG+= \
-#      CONFIG_HOSTAUDIO
-  FILES:= \
-       $(LINUX_DIR)/sound/soundcore.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/arch/um/drivers/hostaudio.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
-endef
-
-define KernelPackage/soundcore/description
- Kernel modules for sound support
-endef
-
-$(eval $(call KernelPackage,soundcore))
-
-
-define KernelPackage/loop
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Loopback device support
-  KCONFIG:=CONFIG_BLK_DEV_LOOP
-  FILES:=$(LINUX_DIR)/drivers/block/loop.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,loop)
-endef
-
-define KernelPackage/loop/description
- Kernel module for loopback device support
-endef
-
-$(eval $(call KernelPackage,loop))
-
-
-define KernelPackage/nbd
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Network block device support
-  KCONFIG:=CONFIG_BLK_DEV_NBD
-  FILES:=$(LINUX_DIR)/drivers/block/nbd.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,nbd)
-endef
-
-define KernelPackage/nbd/description
- Kernel module for network block device support
-endef
-
-$(eval $(call KernelPackage,nbd))
-
-
-define KernelPackage/capi
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CAPI Support
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:= \
-       CONFIG_ISDN \
-       CONFIG_ISDN_CAPI \
-       CONFIG_ISDN_CAPI_CAPI20
-  FILES:= \
-       $(LINUX_DIR)/drivers/isdn/capi/kernelcapi.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/isdn/capi/capi.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,kernelcapi capi)
-endef
-
-define KernelPackage/capi/description
- Kernel module for basic CAPI support
-endef
-
-$(eval $(call KernelPackage,capi))
-
-
 define KernelPackage/pcmcia-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PCMCIA/CardBus support
@@ -289,10 +174,11 @@ endef
 $(eval $(call KernelPackage,pcmcia-serial))
 
 
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
 define KernelPackage/bluetooth
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Bluetooth support
-  DEPENDS:=@USB_SUPPORT
+  DEPENDS:=@USB_SUPPORT @!TARGET_atheros @!TARGET_uml
   KCONFIG:= \
        CONFIG_BLUEZ \
        CONFIG_BLUEZ_L2CAP \
@@ -417,6 +303,22 @@ endef
 $(eval $(call KernelPackage,leds-net48xx))
 
 
+define KernelPackage/leds-wrap
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PCengines WRAP LED support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_LEDS_WRAP
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+endef
+
+define KernelPackage/leds-wrap/description
+ Kernel module for PCengines WRAP LEDs
+endef
+
+$(eval $(call KernelPackage,leds-wrap))
+
+
 define KernelPackage/nsc-gpio
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Natsemi GPIO support