kernel: add Marvell SoC built-in RTC to modules
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index 1bf1755d32f8c7446ab0f6b78434179246b01bf1..773a2bc193e8174475c6673fcb8a77a8d2cad07a 100644 (file)
@@ -731,6 +731,23 @@ endef
 
 $(eval $(call KernelPackage,pwm-gpio))
 
+
+define KernelPackage/rtc-marvell
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell SoC built-in RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=@TARGET_kirkwood||TARGET_orion
+  KCONFIG:=CONFIG_RTC_DRV_MV
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-mv)
+endef
+
+define KernelPackage/rtc-marvell/description
+ Kernel module for Marvell SoC built-in RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-marvell))
+
 define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF8563/Epson RTC8564 RTC support