package/kernel: add module for the Booke watchdog
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index abac4811d49f79dde282767647990b112bbee4c1..d6eab58704896a3d7df5235f30c463616dde3f44 100644 (file)
@@ -720,6 +720,24 @@ endef
 $(eval $(call KernelPackage,wdt-ath79))
 
 
+define KernelPackage/booke-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PowerPC Book-E Watchdog Timer
+  DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
+  KCONFIG:=\
+       CONFIG_BOOKE_WDT_DEFAULT_TIMEOUT=38 \
+       CONFIG_BOOKE_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,booke_wdt)
+endef
+
+define KernelPackage/booke-wdt/description
+  Kernel module for PowerPC Book-E Watchdog Timer.
+endef
+
+$(eval $(call KernelPackage,booke-wdt))
+
+
 define KernelPackage/pwm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PWM generic API
@@ -896,7 +914,15 @@ define KernelPackage/serial-8250
        CONFIG_SERIAL_8250_SHARE_IRQ=y \
        CONFIG_SERIAL_8250_DETECT_IRQ=n \
        CONFIG_SERIAL_8250_RSA=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+else
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+ else
+  FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
+ endif
+endif
 endef
 
 define KernelPackage/serial-8250/description