package/kernel: add package for MTD testing modules
[openwrt/svn-archive/archive.git] / package / kernel / modules / other.mk
index 2b6b86bfc11d3f524d9feca45028ab0105fbed50..ff42ebada51eb63f03248cdcaf2032c2d89f0e77 100644 (file)
@@ -24,8 +24,8 @@ define KernelPackage/bluetooth
        CONFIG_BLUEZ_HCIUSB \
        CONFIG_BLUEZ_HIDP \
        CONFIG_BT \
-       CONFIG_BT_L2CAP \
-       CONFIG_BT_SCO \
+       CONFIG_BT_L2CAP=y \
+       CONFIG_BT_SCO=y \
        CONFIG_BT_RFCOMM \
        CONFIG_BT_BNEP \
        CONFIG_BT_HCIBTUSB \
@@ -108,6 +108,37 @@ endef
 $(eval $(call KernelPackage,eeprom-93cx6))
 
 
+define KernelPackage/eeprom-at24
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=EEPROM AT24 support
+  KCONFIG:=CONFIG_EEPROM_AT24
+  DEPENDS:=+kmod-i2c-core
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at24.ko
+  AUTOLOAD:=$(call AutoLoad,60,at24)
+endef
+
+define KernelPackage/eeprom-at24/description
+ Kernel module for most I2C EEPROMs
+endef
+
+$(eval $(call KernelPackage,eeprom-at24))
+
+
+define KernelPackage/eeprom-at25
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=EEPROM AT25 support
+  KCONFIG:=CONFIG_EEPROM_AT25
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at25.ko
+  AUTOLOAD:=$(call AutoLoad,61,at25)
+endef
+
+define KernelPackage/eeprom-at25/description
+ Kernel module for most SPI EEPROMs
+endef
+
+$(eval $(call KernelPackage,eeprom-at25))
+
+
 define KernelPackage/gpio-cs5535
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver
@@ -127,10 +158,15 @@ $(eval $(call KernelPackage,gpio-cs5535))
 define KernelPackage/gpio-cs5535-new
   SUBMENU:=$(OTHER_MENU)
   TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
-  DEPENDS:=@TARGET_x86 @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
+  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
   KCONFIG:=CONFIG_GPIO_CS5535
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
+  AUTOLOAD:=$(call AutoLoad,50,gpio-cs5535)
+else
   FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
   AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
+endif
 endef
 
 define KernelPackage/gpio-cs5535-new/description
@@ -221,12 +257,10 @@ $(eval $(call KernelPackage,gpio-nxp-74hc164))
 define KernelPackage/hid
   SUBMENU:=$(OTHER_MENU)
   TITLE:=HID Devices
-  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call SetDepends/hid)
-  $(call AddDepends/input)
+  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/hid/description
@@ -240,7 +274,6 @@ define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core
   KCONFIG:=CONFIG_INPUT
-  $(call SetDepends/input)
   FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
   AUTOLOAD:=$(call AutoLoad,19,input-core)
 endef
@@ -517,6 +550,30 @@ endef
 $(eval $(call KernelPackage,ssb))
 
 
+define KernelPackage/bcma
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=BCMA support
+  DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx
+  KCONFIG:=\
+       CONFIG_BCMA \
+       CONFIG_BCMA_POSSIBLE=y \
+       CONFIG_BCMA_BLOCKIO=y \
+       CONFIG_BCMA_HOST_PCI_POSSIBLE=y \
+       CONFIG_BCMA_HOST_PCI=y \
+       CONFIG_BCMA_DRIVER_MIPS=n \
+       CONFIG_BCMA_DRIVER_PCI_HOSTMODE=n \
+       CONFIG_BCMA_DEBUG=n
+  FILES:=$(LINUX_DIR)/drivers/bcma/bcma.ko
+  AUTOLOAD:=$(call AutoLoad,29,bcma)
+endef
+
+define KernelPackage/bcma/description
+   Bus driver for Broadcom specific Advanced Microcontroller Bus Architecture.
+endef
+
+$(eval $(call KernelPackage,bcma))
+
+
 define KernelPackage/wdt-geode
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Geode/LX Watchdog timer
@@ -552,7 +609,7 @@ $(eval $(call KernelPackage,cs5535-clockevt))
 define KernelPackage/cs5535-mfgpt
   SUBMENU:=$(OTHER_MENU)
   TITLE:=CS5535/6 Multifunction General Purpose Timer
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
   KCONFIG:=CONFIG_CS5535_MFGPT
   FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
   AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
@@ -565,6 +622,24 @@ endef
 $(eval $(call KernelPackage,cs5535-mfgpt))
 
 
+define KernelPackage/cs5535-mfd
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=CS5535/6 Multifunction General Purpose Driver
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_MFD_CS5535
+  FILES:= \
+       $(LINUX_DIR)/drivers/mfd/mfd-core.ko \
+       $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko 
+  AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
+endef
+
+define KernelPackage/cs5535-mfd/description
+  Core driver for CS5535/CS5536 MFD functions.
+endef
+
+$(eval $(call KernelPackage,cs5535-mfd))
+
+
 define KernelPackage/wdt-omap
   SUBMENU:=$(OTHER_MENU)
   TITLE:=OMAP Watchdog timer
@@ -660,7 +735,7 @@ $(eval $(call KernelPackage,pwm-gpio))
 
 define KernelPackage/rtc-core
   SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@(!LINUX_3_0||BROKEN)
+  DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN
   TITLE:=Real Time Clock class support
   KCONFIG:=CONFIG_RTC_CLASS
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
@@ -690,6 +765,22 @@ endef
 $(eval $(call KernelPackage,rtc-pcf8563))
 
 
+define KernelPackage/rtc-pcf2123
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Philips PCF2123 RTC support
+  DEPENDS:=+kmod-rtc-core
+  KCONFIG:=CONFIG_RTC_DRV_PCF2123
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)
+endef
+
+define KernelPackage/rtc-pcf2123/description
+ Kernel module for Philips PCF2123 RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2123))
+
+
 define KernelPackage/n810bm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Nokia N810 battery management driver
@@ -705,3 +796,25 @@ define KernelPackage/n810bm/description
 endef
 
 $(eval $(call KernelPackage,n810bm))
+
+
+define KernelPackage/mtdtests
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=MTD subsystem tests
+  KCONFIG:=CONFIG_MTD_TESTS
+  FILES:=\
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_nandecctest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_oobtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_pagetest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_readtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_speedtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_stresstest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_subpagetest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_torturetest.ko
+endef
+
+define KernelPackage/mtdtests/description
+ Kernel modules for MTD subsystem/driver testing.
+endef
+
+$(eval $(call KernelPackage,mtdtests))