kernel: include the xfrm_algo module on 3.6+ (fixes #12552)
[openwrt/svn-archive/archive.git] / package / kernel / modules / pcmcia.mk
index 7ea259923fbe82234b4a572c29ef3c6e9ad5ad4b..cac727719c380a47cd68000ebe938dafa48aac78 100644 (file)
@@ -69,15 +69,7 @@ define KernelPackage/pcmcia-serial
   KCONFIG:= \
        CONFIG_PCMCIA_SERIAL_CS \
        CONFIG_SERIAL_8250_CS
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
-    ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
-       FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
-    else
-       FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
-    endif
-  else
-    FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.ko
-  endif
+    FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
   AUTOLOAD:=$(call AutoLoad,45,serial_cs)
 endef