Add audio feature flag.
[openwrt/svn-archive/archive.git] / package / kernel / modules / sound.mk
index 0e7cefe5693d25a8edb656cdbcdd0c3432ad3fc2..53f65e5ad10aebd621d2c85c174603393e94e390 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT||TARGET_uml
+  DEPENDS:=@AUDIO_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -76,10 +76,16 @@ endef
 
 $(eval $(call KernelPackage,sound-core))
 
-define KernelPackage/sound-i8x0
+
+define KernelPackage/sound/Depends
   SUBMENU:=$(SOUND_MENU)
+  DEPENDS:=kmod-sound-core $(1)
+endef
+
+
+define KernelPackage/sound-i8x0
+$(call KernelPackage/sound/Depends,@!TARGET_uml)
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
-  DEPENDS:=kmod-sound-core @!TARGET_uml
   KCONFIG:=CONFIG_SND_INTEL8X0
   FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
@@ -93,10 +99,10 @@ endef
 
 $(eval $(call KernelPackage,sound-i8x0))
 
+
 define KernelPackage/sound-ps3
-  SUBMENU:=$(SOUND_MENU)
+$(call KernelPackage/sound/Depends,@TARGET_ps3||TARGET_ps3chk)
   TITLE:=PS3 Audio
-  DEPENDS:=kmod-sound-core @TARGET_ps3||@TARGET_ps3chk
   KCONFIG:=CONFIG_SND_PS3 \
                CONFIG_SND_PPC=y \
                CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
@@ -110,10 +116,10 @@ endef
 
 $(eval $(call KernelPackage,sound-ps3))
 
+
 define KernelPackage/sound-cs5535audio
-  SUBMENU:=$(SOUND_MENU)
+$(call KernelPackage/sound/Depends,@!TARGET_uml)
   TITLE:=CS5535 PCI Controller
-  DEPENDS:=kmod-sound-core @!TARGET_uml
   KCONFIG:=CONFIG_SND_CS5535AUDIO
   FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/sound/ac97_bus.$(LINUX_KMOD_SUFFIX) \