package/kernel: move pcspkr to sound.mk
[openwrt/svn-archive/archive.git] / package / kernel / modules / sound.mk
index 0e7cefe5693d25a8edb656cdbcdd0c3432ad3fc2..ef6b0a9daf01fddf546188d6b548c69a25ed86cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,10 +7,26 @@
 
 SOUND_MENU:=Sound Support
 
+define KernelPackage/pcspkr
+  SUBMENU:=$(SOUND_MENU)
+  TITLE:=PC speaker support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:=CONFIG_INPUT_PCSPKR
+  FILES:=$(LINUX_DIR)/drivers/input/misc/pcspkr.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,pcspkr)
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))
+
+
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT||TARGET_uml
+  DEPENDS:=@AUDIO_SUPPORT
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -26,6 +42,7 @@ define KernelPackage/sound-core
        CONFIG_SND_PCM_OSS \
        CONFIG_SND_MIXER_OSS \
        CONFIG_SOUND_OSS_CORE_PRECLAIM=y
+  $(call AddDepends/input)
 endef
 
 define KernelPackage/sound-core/2.4
@@ -76,10 +93,16 @@ endef
 
 $(eval $(call KernelPackage,sound-core))
 
-define KernelPackage/sound-i8x0
+
+define AddDepends/sound
   SUBMENU:=$(SOUND_MENU)
+  DEPENDS:=kmod-sound-core $(1)
+endef
+
+
+define KernelPackage/sound-i8x0
+$(call AddDepends/sound,@!TARGET_uml)
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
-  DEPENDS:=kmod-sound-core @!TARGET_uml
   KCONFIG:=CONFIG_SND_INTEL8X0
   FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
@@ -93,27 +116,10 @@ endef
 
 $(eval $(call KernelPackage,sound-i8x0))
 
-define KernelPackage/sound-ps3
-  SUBMENU:=$(SOUND_MENU)
-  TITLE:=PS3 Audio
-  DEPENDS:=kmod-sound-core @TARGET_ps3||@TARGET_ps3chk
-  KCONFIG:=CONFIG_SND_PS3 \
-               CONFIG_SND_PPC=y \
-               CONFIG_SND_PS3_DEFAULT_START_DELAY=2000
-  FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
-endef
-
-define KernelPackage/sound-ps3/description
- support for the integrated PS3 audio device
-endef
-
-$(eval $(call KernelPackage,sound-ps3))
 
 define KernelPackage/sound-cs5535audio
-  SUBMENU:=$(SOUND_MENU)
+$(call AddDepends/sound,@!TARGET_uml)
   TITLE:=CS5535 PCI Controller
-  DEPENDS:=kmod-sound-core @!TARGET_uml
   KCONFIG:=CONFIG_SND_CS5535AUDIO
   FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.$(LINUX_KMOD_SUFFIX) \
        $(LINUX_DIR)/sound/ac97_bus.$(LINUX_KMOD_SUFFIX) \
@@ -126,3 +132,16 @@ define KernelPackage/sound-cs5535audio/description
 endef
 
 $(eval $(call KernelPackage,sound-cs5535audio))
+
+
+define KernelPackage/sound-soc-core
+$(call AddDepends/sound)
+  TITLE:=SoC sound support
+  KCONFIG:= \
+       CONFIG_SND_SOC \
+       CONFIG_SND_SOC_ALL_CODECS=n
+  FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
+  AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)
+endef
+
+$(eval $(call KernelPackage,sound-soc-core))