[package] pcmcia-core: fix a typo
[openwrt/svn-archive/archive.git] / package / kernel / modules / video.mk
index 4a360316486764e43f68f1aafc5578808dfcbb83..bd950e34365a0344e3c7d1b7bb2eb10386233949 100644 (file)
@@ -11,6 +11,7 @@ VIDEO_MENU:=Video Support
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
+  DEPENDS:= @!TARGET_uml
   KCONFIG:= \
        CONFIG_VIDEO_DEV \
        CONFIG_VIDEO_V4L1=y \
@@ -60,6 +61,58 @@ endef
 $(eval $(call KernelPackage,video-cpia2))
 
 
+define KernelPackage/video-konica
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Konica USB webcam support
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core
+  KCONFIG:=CONFIG_USB_KONICAWC
+  FILES:=$(LINUX_DIR)/drivers/media/video/usbvideo/konicawc.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,70,konicawc)
+endef
+
+define KernelPackage/video-konica/description
+ Kernel support for webcams based on a Konica chipset. This is known to 
+ work with the Intel YC76 webcam.
+endef
+
+$(eval $(call KernelPackage,video-konica))
+
+
+define KernelPackage/video-ov511
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=OV511 USB webcam support
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
+  KCONFIG:=CONFIG_VIDEO_OV511
+  FILES:=$(LINUX_DIR)/drivers/media/video/ov511.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,70,ov511)
+endef
+
+
+define KernelPackage/video-ov511/description
+ Kernel modules for supporting OmniVision OV511 USB webcams.
+endef
+
+$(eval $(call KernelPackage,video-ov511))
+
+
+define KernelPackage/video-ovcamchip
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=OV6xxx/OV7xxx Camera Chip support
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-i2c-core kmod-video-core
+  KCONFIG:=CONFIG_VIDEO_OVCAMCHIP
+  FILES:=$(LINUX_DIR)/drivers/media/video/ovcamchip/ovcamchip.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,70,ovcamchip)
+endef
+
+
+define KernelPackage/video-ovcamchip/description
+ Kernel modules for supporting OmniVision OV6xxx and OV7xxx series of 
+ camera chips.
+endef
+
+$(eval $(call KernelPackage,video-ovcamchip))
+
+
 define KernelPackage/video-pwc
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Philips USB webcam support