kernel: add more SCTP related configuration symbols
[openwrt/svn-archive/archive.git] / package / kernel / modules / video.mk
index 6bc19fd4f946a8eec4c971a4adcd19d9be90bd21..e652e8a4f0e89b1b30a8665eb26d1ddb2d7ec897 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Copyright (C) 2009 David Cooper <dave@kupesoft.com>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 
 VIDEO_MENU:=Video Support
 
-define KernelPackage/video-core
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.7.0)),1)
+V4L2_DIR=v4l2-core
+V4L2_USB_DIR=usb
+else
+V4L2_DIR=video
+V4L2_USB_DIR=video
+endif
+
+
+define KernelPackage/fb
   SUBMENU:=$(VIDEO_MENU)
-  TITLE=Video4Linux support
-  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
-  KCONFIG:= \
-       CONFIG_MEDIA_SUPPORT=m \
-       CONFIG_VIDEO_DEV \
-       CONFIG_VIDEO_V4L1=y \
-       CONFIG_VIDEO_ALLOW_V4L1=y \
-       CONFIG_VIDEO_CAPTURE_DRIVERS=y \
-       CONFIG_V4L_USB_DRIVERS=y 
+  TITLE:=Framebuffer support
+  DEPENDS:=@DISPLAY_SUPPORT
+  KCONFIG:=CONFIG_FB
+  FILES:=$(LINUX_DIR)/drivers/video/fb.ko
+  AUTOLOAD:=$(call AutoLoad,06,fb)
 endef
 
-define KernelPackage/video-core/2.4
-  FILES:=$(LINUX_DIR)/drivers/media/video/videodev.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,videodev)
+define KernelPackage/fb/description
+  Kernel support for framebuffers
 endef
 
-define KernelPackage/video-core/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/media/video/v4l2-common.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/media/video/v4l1-compat.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/media/video/videodev.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60, \
-       v4l1-compat \
-       videodev \
-       v4l2-common \
-  )
+$(eval $(call KernelPackage,fb))
+
+define KernelPackage/fb-cfb-fillrect
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software rectangle filling support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_FILLRECT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbfillrect.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
 endef
 
-define KernelPackage/video-core/description
- Kernel modules for Video4Linux support
+define KernelPackage/fb-cfb-fillrect/description
+  Kernel support for software rectangle filling
 endef
 
-$(eval $(call KernelPackage,video-core))
+$(eval $(call KernelPackage,fb-cfb-fillrect))
 
 
-define KernelPackage/video/Depends
+define KernelPackage/fb-cfb-copyarea
   SUBMENU:=$(VIDEO_MENU)
-  DEPENDS+=kmod-video-core $(1)
+  TITLE:=Framebuffer software copy area support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_COPYAREA
+  FILES:=$(LINUX_DIR)/drivers/video/cfbcopyarea.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
 endef
 
+define KernelPackage/fb-cfb-copyarea/description
+  Kernel support for software copy area
+endef
 
-define KernelPackage/video-cpia2
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
-  TITLE:=CPIA2 video driver
-  KCONFIG:=CONFIG_VIDEO_CPIA2
-  FILES:=$(LINUX_DIR)/drivers/media/video/cpia2/cpia2.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,70,cpia2)
+$(eval $(call KernelPackage,fb-cfb-copyarea))
+
+define KernelPackage/fb-cfb-imgblt
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer software image blit support
+  DEPENDS:=+kmod-fb
+  KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
+  FILES:=$(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
 endef
 
-define KernelPackage/video-cpia2/description
- Kernel modules for supporting CPIA2 USB based cameras.
+define KernelPackage/fb-cfb-imgblt/description
+  Kernel support for software image blitting
 endef
 
-$(eval $(call KernelPackage,video-cpia2))
+$(eval $(call KernelPackage,fb-cfb-imgblt))
 
 
-define KernelPackage/video-konica
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
-  TITLE:=Konica USB webcam support
-  KCONFIG:=CONFIG_USB_KONICAWC
-  FILES:=$(LINUX_DIR)/drivers/media/video/usbvideo/konicawc.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,70,konicawc)
+define KernelPackage/video-core
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE=Video4Linux support
+  DEPENDS:=@PCI_SUPPORT||USB_SUPPORT
+  KCONFIG:= \
+       CONFIG_MEDIA_SUPPORT=m \
+       CONFIG_MEDIA_CAMERA_SUPPORT=y \
+       CONFIG_VIDEO_DEV \
+       CONFIG_VIDEO_V4L1=y \
+       CONFIG_VIDEO_ALLOW_V4L1=y \
+       CONFIG_VIDEO_CAPTURE_DRIVERS=y \
+       CONFIG_V4L_USB_DRIVERS=y \
+       CONFIG_V4L_PCI_DRIVERS=y \
+       CONFIG_V4L_PLATFORM_DRIVERS=y \
+       CONFIG_V4L_ISA_PARPORT_DRIVERS=y
+  FILES:= \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/v4l2-common.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videodev.ko
+  AUTOLOAD:=$(call AutoLoad,60, videodev v4l2-common)
 endef
 
-define KernelPackage/video-konica/description
- Kernel support for webcams based on a Konica chipset. This is known to 
- work with the Intel YC76 webcam.
+define KernelPackage/video-core/description
+ Kernel modules for Video4Linux support
 endef
 
-$(eval $(call KernelPackage,video-konica))
+$(eval $(call KernelPackage,video-core))
 
 
-define KernelPackage/video-ov511
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
-  TITLE:=OV511 USB webcam support
-  KCONFIG:=CONFIG_VIDEO_OV511
-  FILES:=$(LINUX_DIR)/drivers/media/video/ov511.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,70,ov511)
+define AddDepends/video
+  SUBMENU:=$(VIDEO_MENU)
+  DEPENDS+=kmod-video-core $(1)
 endef
 
-
-define KernelPackage/video-ov511/description
- Kernel modules for supporting OmniVision OV511 USB webcams.
+define AddDepends/camera
+  SUBMENU:=$(VIDEO_MENU)
+  KCONFIG+=CONFIG_MEDIA_USB_SUPPORT=y \
+        CONFIG_MEDIA_CAMERA_SUPPORT=y
+  DEPENDS+=kmod-video-core $(1)
 endef
 
-$(eval $(call KernelPackage,video-ov511))
 
+define KernelPackage/video-videobuf2
+  TITLE:=videobuf2 lib
+  KCONFIG:= \
+       CONFIG_VIDEOBUF2_CORE \
+       CONFIG_VIDEOBUF2_MEMOPS \
+       CONFIG_VIDEOBUF2_VMALLOC
+  FILES:= \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-core.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-memops.ko \
+       $(LINUX_DIR)/drivers/media/$(V4L2_DIR)/videobuf2-vmalloc.ko
+  AUTOLOAD:=$(call AutoLoad,65,videobuf2-core videobuf2-memops videobuf2-vmalloc)
+  $(call AddDepends/video)
+endef
 
-define KernelPackage/video-ovcamchip
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-i2c-core)
-  TITLE:=OV6xxx/OV7xxx Camera Chip support
-  KCONFIG:=CONFIG_VIDEO_OVCAMCHIP
-  FILES:=$(LINUX_DIR)/drivers/media/video/ovcamchip/ovcamchip.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,70,ovcamchip)
+define KernelPackage/video-videobuf2/description
+ Kernel modules that implements three basic types of media buffers.
 endef
 
+$(eval $(call KernelPackage,video-videobuf2))
 
-define KernelPackage/video-ovcamchip/description
- Kernel modules for supporting OmniVision OV6xxx and OV7xxx series of 
- camera chips.
+
+define KernelPackage/video-cpia2
+  TITLE:=CPIA2 video driver
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
+  KCONFIG:=CONFIG_VIDEO_CPIA2
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/cpia2/cpia2.ko
+  AUTOLOAD:=$(call AutoLoad,70,cpia2)
+  $(call AddDepends/camera)
 endef
 
-$(eval $(call KernelPackage,video-ovcamchip))
+define KernelPackage/video-cpia2/description
+ Kernel modules for supporting CPIA2 USB based cameras.
+endef
+
+$(eval $(call KernelPackage,video-cpia2))
 
 
 define KernelPackage/video-sn9c102
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
   TITLE:=SN9C102 Camera Chip support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
   KCONFIG:=CONFIG_USB_SN9C102
-  FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/sn9c102/sn9c102.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_sn9c20x)
+  $(call AddDepends/camera)
 endef
 
 
@@ -133,13 +176,14 @@ $(eval $(call KernelPackage,video-sn9c102))
 
 
 define KernelPackage/video-pwc
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
   TITLE:=Philips USB webcam support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= \
        CONFIG_USB_PWC \
        CONFIG_USB_PWC_DEBUG=n
-  FILES:=$(LINUX_DIR)/drivers/media/video/pwc/pwc.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/pwc/pwc.ko
   AUTOLOAD:=$(call AutoLoad,70,pwc)
+  $(call AddDepends/camera)
 endef
 
 
@@ -150,11 +194,13 @@ endef
 $(eval $(call KernelPackage,video-pwc))
 
 define KernelPackage/video-uvc
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
   TITLE:=USB Video Class (UVC) support
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
   KCONFIG:= CONFIG_USB_VIDEO_CLASS
-  FILES:=$(LINUX_DIR)/drivers/media/video/uvc/uvcvideo.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
   AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
+  $(call AddDepends/camera)
+  $(call AddDepends/input)
 endef
 
 
@@ -166,12 +212,13 @@ $(eval $(call KernelPackage,video-uvc))
 
 
 define KernelPackage/video-gspca-core
-$(call KernelPackage/video/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
   MENU:=1
   TITLE:=GSPCA webcam core support framework
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-input-core
   KCONFIG:=CONFIG_USB_GSPCA
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_main.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_main.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_main)
+  $(call AddDepends/camera)
 endef
 
 define KernelPackage/video-gspca-core/description
@@ -182,18 +229,18 @@ endef
 $(eval $(call KernelPackage,video-gspca-core))
 
 
-define KernelPackage/video-gspca/Depends
+define AddDepends/camera-gspca
   SUBMENU:=$(VIDEO_MENU)
   DEPENDS+=kmod-video-gspca-core $(1)
 endef
 
 
 define KernelPackage/video-gspca-conex
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=conex webcam support
   KCONFIG:=CONFIG_USB_GSPCA_CONEX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_conex.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_conex.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_conex)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-conex/description
@@ -204,11 +251,11 @@ $(eval $(call KernelPackage,video-gspca-conex))
 
 
 define KernelPackage/video-gspca-etoms
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=etoms webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ETOMS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_etoms.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_etoms.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_etoms)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-etoms/description
@@ -219,11 +266,11 @@ $(eval $(call KernelPackage,video-gspca-etoms))
 
 
 define KernelPackage/video-gspca-finepix
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=finepix webcam support
   KCONFIG:=CONFIG_USB_GSPCA_FINEPIX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_finepix.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_finepix.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_finepix)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-finepix/description
@@ -234,11 +281,11 @@ $(eval $(call KernelPackage,video-gspca-finepix))
 
 
 define KernelPackage/video-gspca-mars
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=mars webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MARS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_mars.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mars.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_mars)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mars/description
@@ -249,11 +296,11 @@ $(eval $(call KernelPackage,video-gspca-mars))
 
 
 define KernelPackage/video-gspca-mr97310a
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=mr97310a webcam support
   KCONFIG:=CONFIG_USB_GSPCA_MR97310A
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_mr97310a.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_mr97310a.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_mr97310a)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-mr97310a/description
@@ -264,11 +311,11 @@ $(eval $(call KernelPackage,video-gspca-mr97310a))
 
 
 define KernelPackage/video-gspca-ov519
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=ov519 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV519
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov519.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov519.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_ov519)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov519/description
@@ -279,11 +326,11 @@ $(eval $(call KernelPackage,video-gspca-ov519))
 
 
 define KernelPackage/video-gspca-ov534
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=ov534 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_OV534
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_ov534.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_ov534)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-ov534/description
@@ -293,12 +340,27 @@ endef
 $(eval $(call KernelPackage,video-gspca-ov534))
 
 
+define KernelPackage/video-gspca-ov534-9
+  TITLE:=ov534-9 webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_OV534_9
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_ov534_9.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_ov534_9)
+  $(call AddDepends/camera-gspca)
+endef
+
+define KernelPackage/video-gspca-ov534-9/description
+ The OV534-9 USB Camera Driver (ov534_9) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-ov534-9))
+
+
 define KernelPackage/video-gspca-pac207
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=pac207 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC207
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_pac207.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac207.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_pac207)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac207/description
@@ -309,11 +371,11 @@ $(eval $(call KernelPackage,video-gspca-pac207))
 
 
 define KernelPackage/video-gspca-pac7311
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=pac7311 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_PAC7311
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_pac7311.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_pac7311.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_pac7311)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-pac7311/description
@@ -323,12 +385,27 @@ endef
 $(eval $(call KernelPackage,video-gspca-pac7311))
 
 
+define KernelPackage/video-gspca-se401
+  TITLE:=se401 webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_SE401
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_se401.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_se401)
+  $(call AddDepends/camera-gspca)
+endef
+
+define KernelPackage/video-gspca-se401/description
+ The SE401 USB Camera Driver kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-se401))
+
+
 define KernelPackage/video-gspca-sn9c20x
-$(call KernelPackage/video-gspca/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
   TITLE:=sn9c20x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SN9C20X
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sn9c20x.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,75,sn9c20x)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sn9c20x.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_sn9c20x)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sn9c20x/description
@@ -339,11 +416,11 @@ $(eval $(call KernelPackage,video-gspca-sn9c20x))
 
 
 define KernelPackage/video-gspca-sonixb
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=sonixb webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXB
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sonixb.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixb.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sonixb)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixb/description
@@ -354,11 +431,11 @@ $(eval $(call KernelPackage,video-gspca-sonixb))
 
 
 define KernelPackage/video-gspca-sonixj
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=sonixj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SONIXJ
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sonixj.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sonixj.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sonixj)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sonixj/description
@@ -369,11 +446,11 @@ $(eval $(call KernelPackage,video-gspca-sonixj))
 
 
 define KernelPackage/video-gspca-spca500
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca500 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA500
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca500.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca500.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca500)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca500/description
@@ -384,11 +461,11 @@ $(eval $(call KernelPackage,video-gspca-spca500))
 
 
 define KernelPackage/video-gspca-spca501
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca501 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA501
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca501.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca501.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca501)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca501/description
@@ -399,11 +476,11 @@ $(eval $(call KernelPackage,video-gspca-spca501))
 
 
 define KernelPackage/video-gspca-spca505
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca505 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA505
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca505.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca505.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca505)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca505/description
@@ -414,11 +491,11 @@ $(eval $(call KernelPackage,video-gspca-spca505))
 
 
 define KernelPackage/video-gspca-spca506
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca506 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA506
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca506.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca506.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca506)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca506/description
@@ -429,11 +506,11 @@ $(eval $(call KernelPackage,video-gspca-spca506))
 
 
 define KernelPackage/video-gspca-spca508
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca508 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA508
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca508.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca508.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca508)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca508/description
@@ -444,11 +521,11 @@ $(eval $(call KernelPackage,video-gspca-spca508))
 
 
 define KernelPackage/video-gspca-spca561
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=spca561 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SPCA561
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_spca561.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_spca561.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_spca561)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-spca561/description
@@ -459,11 +536,11 @@ $(eval $(call KernelPackage,video-gspca-spca561))
 
 
 define KernelPackage/video-gspca-sq905
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=sq905 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sq905.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sq905)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905/description
@@ -474,11 +551,11 @@ $(eval $(call KernelPackage,video-gspca-sq905))
 
 
 define KernelPackage/video-gspca-sq905c
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=sq905c webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SQ905C
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sq905c.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sq905c.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sq905c)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sq905c/description
@@ -489,11 +566,11 @@ $(eval $(call KernelPackage,video-gspca-sq905c))
 
 
 define KernelPackage/video-gspca-stk014
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=stk014 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_STK014
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_stk014.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_stk014.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_stk014)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stk014/description
@@ -504,11 +581,11 @@ $(eval $(call KernelPackage,video-gspca-stk014))
 
 
 define KernelPackage/video-gspca-sunplus
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=sunplus webcam support
   KCONFIG:=CONFIG_USB_GSPCA_SUNPLUS
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sunplus.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_sunplus.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_sunplus)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-sunplus/description
@@ -519,11 +596,11 @@ $(eval $(call KernelPackage,video-gspca-sunplus))
 
 
 define KernelPackage/video-gspca-t613
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=t613 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_T613
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_t613.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_t613.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_t613)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-t613/description
@@ -534,11 +611,11 @@ $(eval $(call KernelPackage,video-gspca-t613))
 
 
 define KernelPackage/video-gspca-tv8532
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=tv8532 webcam support
   KCONFIG:=CONFIG_USB_GSPCA_TV8532
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_tv8532.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_tv8532.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_tv8532)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-tv8532/description
@@ -549,11 +626,11 @@ $(eval $(call KernelPackage,video-gspca-tv8532))
 
 
 define KernelPackage/video-gspca-vc032x
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=vc032x webcam support
   KCONFIG:=CONFIG_USB_GSPCA_VC032X
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_vc032x.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_vc032x.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_vc032x)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-vc032x/description
@@ -564,11 +641,11 @@ $(eval $(call KernelPackage,video-gspca-vc032x))
 
 
 define KernelPackage/video-gspca-zc3xx
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=zc3xx webcam support
   KCONFIG:=CONFIG_USB_GSPCA_ZC3XX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_zc3xx.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_zc3xx.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_zc3xx)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-zc3xx/description
@@ -579,11 +656,11 @@ $(eval $(call KernelPackage,video-gspca-zc3xx))
 
 
 define KernelPackage/video-gspca-m5602
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=m5602 webcam support
   KCONFIG:=CONFIG_USB_M5602
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/m5602/gspca_m5602.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/m5602/gspca_m5602.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_m5602)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-m5602/description
@@ -594,11 +671,11 @@ $(eval $(call KernelPackage,video-gspca-m5602))
 
 
 define KernelPackage/video-gspca-stv06xx
-$(call KernelPackage/video-gspca/Depends,)
   TITLE:=stv06xx webcam support
   KCONFIG:=CONFIG_USB_STV06XX
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/stv06xx/gspca_stv06xx.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/stv06xx/gspca_stv06xx.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_stv06xx)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-stv06xx/description
@@ -609,11 +686,11 @@ $(eval $(call KernelPackage,video-gspca-stv06xx))
 
 
 define KernelPackage/video-gspca-gl860
-$(call KernelPackage/video-gspca/Depends,@LINUX_2_6_32)
   TITLE:=gl860 webcam support
   KCONFIG:=CONFIG_USB_GL860
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gl860/gspca_gl860.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gl860/gspca_gl860.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_gl860)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-gl800/description
@@ -624,11 +701,11 @@ $(eval $(call KernelPackage,video-gspca-gl860))
 
 
 define KernelPackage/video-gspca-jeilinj
-$(call KernelPackage/video-gspca/Depends,@LINUX_2_6_32)
   TITLE:=jeilinj webcam support
   KCONFIG:=CONFIG_USB_GSPCA_JEILINJ
-  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_jeilinj.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_jeilinj.ko
   AUTOLOAD:=$(call AutoLoad,75,gspca_jeilinj)
+  $(call AddDepends/camera-gspca)
 endef
 
 define KernelPackage/video-gspca-jeilinj/description
@@ -636,3 +713,18 @@ define KernelPackage/video-gspca-jeilinj/description
 endef
 
 $(eval $(call KernelPackage,video-gspca-jeilinj))
+
+
+define KernelPackage/video-gspca-konica
+  TITLE:=konica webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_KONICA
+  FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/gspca/gspca_konica.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_konica)
+  $(call AddDepends/camera-gspca)
+endef
+
+define KernelPackage/video-gspca-konica/description
+ The Konica USB Camera Driver (konica) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-konica))